Spami send/receive keeps running

For all users, who don't speak German!

Moderator: Forum-Team

Spami send/receive keeps running

Beitragvon px03afk » 19. Jun 2015, 18:13

Sorry if this duplicates a known problem but I can't find it in the forum. Every so often I see the envelope in the tray running continuously for a lot longer than makes any sense. I've left it alone for minutes and still it continues running. I can click on it and bring up the box and cancel and then everything settles down again. It's not a major issue but I was wondering how I might be able to determine why it's happening.
px03afk
Spam-Jäger
Spam-Jäger
 
Beiträge: 23
Registriert: 3. Apr 2012, 13:43

Re: Spami send/receive keeps running

Beitragvon Chactory » 24. Jun 2015, 21:17

Hi px03afk!

I've thought over this problem for a while, but I'm not finding a reason ... Could it be a server problem? Can you find any interesting information in the log files (client.log, server.log, they are in the folder C:\Users\Chactory\AppData\Roaming\Spamihilator)?

Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami send/receive keeps running

Beitragvon px03afk » 25. Jun 2015, 03:37

Hi Chactory,

Thanks for replying. Silly of me to not think of looking in the log files but I didn't and as I am not entirely sure when the problem occurred I can't be sure of finding the correct information. I will try to remember to look the next time I see this happening but it might be some time as this is definitely and intermittent problem.

David
px03afk
Spam-Jäger
Spam-Jäger
 
Beiträge: 23
Registriert: 3. Apr 2012, 13:43

Re: Spami send/receive keeps running

Beitragvon Chactory » 25. Jun 2015, 21:08

Hi David,

thank you for your friendly answer. Your information that the problem is intermittent may indicate that a temporary server problem is the cause.

Sincerely,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami send/receive keeps running

Beitragvon px03afk » 26. Jun 2015, 22:24

Hi Chactory,

Well, the problem has happened again and it looks as though the problem is with completing the connection to the server. The log file has the following in it:

Client Log started at: 26/06/2015 - 14:52:57
14:52:57 S: +OK Spamihilator 1.6.0.0 ready
14:52:57 C: USER xxx.yyy.com&name@xxx.com&995
14:52:57 S: +OK Username accepted
14:52:57 C: PASS ********
15:18:10 S: -ERR

As you can see the password interaction didn't complete, hence the hangup. Isn't there a mechanism which should time this out?

To complete the information, the SSL icon is flashing during this period. I'm running spami 1.6.0 32-bit on a 64-bit version of Windows 10 Technical Preview but I've also had the same issue on a Windows 7 machine. The reason I run the 32-bit version is that I had an issue with the 64-bit version of spami (VB Runtime error - Win7 64 bit posted 16 August 2012) and found that the same problems didn't occur with the 32-bit and so I've stuck with the 32-bit version ever since.

David
px03afk
Spam-Jäger
Spam-Jäger
 
Beiträge: 23
Registriert: 3. Apr 2012, 13:43

Re: Spami send/receive keeps running

Beitragvon Chactory » 5. Jul 2015, 20:09

Hi David,

thank you for your effort to find and quote the relevant lines from the client.log.

Possibly it's only a temporary problem with the server connection. But the trouble is, that Michel Krämer, the program author of Spamihilator, has not finished the programming of a timeout, as you proposed and as asked another user in the past. When you showed the log, I remembered that somebody else asked about a similar problem formerly, and the diskussion went a similar way: a timeout should solve the hang-up.

Does the timeout in the Spamihilator settings / "connection" solve the hang-up?

Sincerely,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami send/receive keeps running

Beitragvon px03afk » 10. Jul 2015, 20:14

Hi Chactory,

Unfortunately the timeout in settings/timeout was set to 60 seconds and the check box for Always abort on timeout was checked.

It would be good to fix this at some time but as you say it is an intermittent problem so not difficult to handle. Main reason for telling you was so you were aware in case there was a bug.

David
px03afk
Spam-Jäger
Spam-Jäger
 
Beiträge: 23
Registriert: 3. Apr 2012, 13:43

Re: Spami send/receive keeps running

Beitragvon px03afk » 20. Mai 2017, 14:59

Have recently run into this issue again and I cannot see any logical explanation for it. Quiter simply, the envelope in the tray keeps running and the only way to recover the situation is to Cancel the connect. Clearly the timeout isn't being activated but could that be because it is a transfer timeout and not an overall timeout? Even if there is a problem with the connection or the remote server it would surely make sense to timeout so that a new attempt is made rather than hanging everything up waiting for manual intervention.
px03afk
Spam-Jäger
Spam-Jäger
 
Beiträge: 23
Registriert: 3. Apr 2012, 13:43

Re: Spami send/receive keeps running

Beitragvon Gast » 19. Aug 2017, 01:19

It would be wonderful if this problem could be fixed. It now keeps happening to me several times a day and so I think it has to be a little more than an intermittent server problem. Even if the fault is with the server, Spami ought to time things out and simply give up this attempt.
Gast
 


Zurück zu English Forum

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron

 industrious-southeast