Regelfilter lässt sich nicht regeln

Brauchen Sie Hilfe beim Benutzen eines Plugins?

Moderator: Forum-Team

Regelfilter lässt sich nicht regeln

Beitragvon alfons » 18. Feb 2010, 08:51

Hallo,

beim Versuch, im Regelfilter neue Regeln zu definieren oder die vorhandenen zu ändern passiert nur eines: Die Schaltfläche Übernehmen wird aktiviert. Es öffnet sich kein neues Fenster. Lediglich die beiden vordefinierten Regeln lassen sich löschen.
Woran kann's liegen, wie bekommt man das Problem gelöst?
Der Effekt tritt nun auf drei verschiedenen Rechnern auf, unter dem Nutzerkonto wie auch als Administrator. Es kommen dort verschiedene Firewalls und Virenscanner zum Einsatz. Gemeinsam ist, dass sie unter win2k laufen.
Hat jemand einen Tipp?

Gruß Alfons
alfons
Spam-Jäger
Spam-Jäger
 
Beiträge: 22
Registriert: 18. Feb 2010, 08:35

Re: Regelfilter lässt sich nicht regeln

Beitragvon Andreas_Z » 18. Feb 2010, 09:16

Hallo alfons!

Nein, habe ich leider nicht. Wenn es eine Incompatibilät mit W2K ist, dann kann ich Sie nicht gegentesten. Ich dieses OS nicht mehr im Einsatz. Bisher bist Du der einzige, der solche Probleme zu berichten hat. Vielleicht hat Michel ja noch Ideen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 18. Feb 2010, 13:40

Hallo zusammen!

Wenn unter Eigenschaften > Regeln bei Klick auf "Neu" nichts passiert, dann könnte es allenfalls daran liegen, daß der Filter nicht aktiviert ist oder die Spamihilator-Installation unter einem anderen User erfolgte ...

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon alfons » 18. Feb 2010, 21:11

Hallo,
Dank für die Hilfeversuche.
Bei mir ist der Regelfilter ist aktiviert und arbeitet auch, denn Mails über 1MB werden von ihm als NonSpam gekennzeichnet und sind im Trainingsbereich entsprechend zu finden.
Installiert hab ich den Spamihilator als update über die alte Version unter dem Administrator-Konto, im Internet bin ich unter dem Nutzer-Konto, so soll es aus Sicherheitsgründen auch sein.
Weder als Administrator noch als Nutzer mit nachträglich erteiltem Schreibrecht auf das Programmverzeichnis lassen sich Regeln definieren.
Da muss also noch etwas anderes sein...

Gruß Alfons
alfons
Spam-Jäger
Spam-Jäger
 
Beiträge: 22
Registriert: 18. Feb 2010, 08:35

Re: Regelfilter lässt sich nicht regeln

Beitragvon Andreas_Z » 19. Feb 2010, 07:43

Hallo alfons!

Entweder ist es ein Defekt, der durch eine Neuinstalltion beheoben werden kann, ober es fehlen auf die Datei rulesfilter.db im Userprofil schreibrechte.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 07:44

Hallo Alfons!

Welche Spamihilator-Version hast Du denn installiert? Ich nehme an, 0.9.9.53, 32Bit. Letztlich erkenne ich von hier aus die Ursache leider nicht. Ich würde, wenn dieses Phänomen bei mir aufträte, selbst wohl zum Mittel der grundlegenden Deinstallation (einschließlich Löschen aller Verzeichnisse und Verknüpfungen) und Neuinstallation greifen ...

Ich finde das nicht so schlimm, weil diese Arbeiten eigentlich sehr rasch erledingt sind. Und ein neuinstallierter Spamihilator benötigt bei mir nur drei Tage, um so gute Ergebnisse abzuliefern, daß er entspannt nebenbei weiterlaufen kann (da ja der Spamwortfilter erstmal viel böses Zeug abfängt, bis der Linkfilter und der Lernende genug Futter zum Lernen hatten).

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 07:45

Hallo Andreas_Z!

Du warst mal wieder schneller. :) Gedankenübertragung, ich gehe auch von einem durch De- und Neuinstallation zu lösenden Problem aus.

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon Andreas_Z » 19. Feb 2010, 07:47

Hallo Chactory!

Ja. Ich denke mal. dass selbst das nicht mal nötige wäre. Einfach die Konfig exporterien und nach der Neuinstallation wieder importieren. Ich kann mir nicht vorstellen, dass der Fehler in der Konfig liegt.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 07:58

Hallo Andreas_Z!

Ich habe noch nie meine Konfiguration in eine neue Installation hinübergerettet, weil ich nie so genau weiß, ob ich definitiv die gleichen Plugins mitinstalliert habe und weil ich immer denke, es könnte doch noch irgendetwas nicht zusammenpassen. :oops: :wink:

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon alfons » 19. Feb 2010, 09:52

Hallo Chactory, hallo Andreas_Z,

installiert habe ich die 32-Bit-Version 0.9.9.53.
Eine Datei ...spamihilator\plugins\rulefilter\rulefilter.db gibt es sowohl im Admin- wie auch im Nutzerprofil. Sie ist jeweils 6144 Byte groß mit identischem Inhalt, Schreibrecht hat der jeweilige Nutzer und der Admin sowieso.
Eine Neuinstallation hab ich noch nicht versucht, weil der Effekt auf drei Rechnern identisch auftritt und daher mit größter Wahrscheinlichkeit ein systematischer Fehler vorliegen muss.
Das werde ich aber wohl als nächsten Schritt in Angriff nehmen müssen und melde dann das Ergebnis.
Die Einstellungen werde ich aber 'rüberretten, da ich relativ viel unter Freunden hinzugefügt habe, auch die Spamwörter sind stark bearbeitet. Ansonsten ist das ja wirklich problemfrei.

Gruß Alfons
alfons
Spam-Jäger
Spam-Jäger
 
Beiträge: 22
Registriert: 18. Feb 2010, 08:35

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 10:23

Hi,

alfons hat geschrieben:installiert habe ich die 32-Bit-Version 0.9.9.53.
Eine Datei ...spamihilator\plugins\rulefilter\rulefilter.db gibt es sowohl im Admin- wie auch im Nutzerprofil.
das ist, was ich meinte ... Wahrscheinlich ist es besser, Spamihilator und jede Aktualisierung und jedes Plugin systematisch gleich zu installieren, und zwar immer unter dem Windows-User, mit dem Du Mails empfängst.

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon alfons » 19. Feb 2010, 17:40

Hallo Chactory!
Folgendes habe ich nun getan (Admin-Konto):
- Spami-Einstellungen gesichert
- mit dem Setup-Assistenten alle Konten ausgeklinkt
- über Systemsteuerung - Software den Spami deinstalliert
- die Reste im Nutzerprofil und unter Programme gelöscht
- den Spami neu installiert (vollständig, ohne Rückholen der alten Einstellungen, ohne weitere Plugins)
- mit dem Setup-Assistenten alle Konten wieder eingeklinkt
- die Einstellungen aufgerufen, klicke auf Regeln und "neu" und siehe:
Es wird die Schaltfläche Übernehmen schwarz, sonst keine Reaktion. :cry:
Das hatten wir vorher schon. Das Deaktivieren vom Kaspersky bringt auch nichts.
Einen Datenfehler im heruntergeladenen Paket schließe ich aus, da ich auf den Rechnern jeweils eigene Downloads durchgeführt habe und der Fehler vermutlich schon beim Start erkannt worden wäre.
Haben wir nun noch eine Option außer der Neuinstallation des Rechners?
Gruß Alfons
alfons
Spam-Jäger
Spam-Jäger
 
Beiträge: 22
Registriert: 18. Feb 2010, 08:35

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 18:35

Hallo Alfons,

alfons hat geschrieben:klicke auf Regeln und "neu" und siehe: Es wird die Schaltfläche Übernehmen schwarz, sonst keine Reaktion. :cry:
tut mir leid für meine unzutreffenden Empfehlungen! Jetzt bin ich wirklich ratlos und hoffe, daß vielleicht der Programmautor, Michel Krämer, eine Idee hat.

alfons hat geschrieben:Haben wir nun noch eine Option außer der Neuinstallation des Rechners?
Nein, so weit sollte es aber nicht gleich kommen ... :lol:

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Regelfilter lässt sich nicht regeln

Beitragvon alfons » 19. Feb 2010, 18:56

Hallo Chactory!
Vielen Dank jedenfalls für den Versuch.
Zum Glück ist es ja nun nicht so, dass das Prog nicht mehr verwendbar wäre. Aber der Regelfilter ist ein schönes Teil, welches ich gern etwas angepasst hätte. Ich bekomme im Schnitt 4-5000 Spams im Monat, im letzten viertel Jahr davon keine über 300kB. In soweit könnte man die voreingestellte Schwelle gut etwas heruntersetzen.
Schauen wir mal, vielleicht hat Michel Krämer ja noch eine Idee, ansonsten werde ich wohl damit leben müssen.
Jetzt werd ich mal die Plugins wieder installieren und einrichten, geht ja zum Glück alles recht einfach.
Gruß Alfons
alfons
Spam-Jäger
Spam-Jäger
 
Beiträge: 22
Registriert: 18. Feb 2010, 08:35

Re: Regelfilter lässt sich nicht regeln

Beitragvon Chactory » 19. Feb 2010, 19:27

Hallo Alfons!

Vielen Dank für Deine freundliche Antwort!
Vielleicht ergibt sich später noch einmal eine Lösung für Dich.
Schau'n mer mal! :wink:

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Nächste

Zurück zu Plugins: Hilfe

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

 industrious-southeast