[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4692: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4694: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Spamihilator • Thema anzeigen - Language file, Filterungsgrund, Etikette
Seite 4 von 6

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 11:26
von dme

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 11:38
von Chactory

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 12:58
von dme

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 13:49
von michel
Hallo,

bei der neusten Version werden bei mir unter Vista die Dateien ins korrekte Verzeichnis geschrieben:
C:\Users\michel\AppData\Roaming\Spamihilator\plugins\impfilter

Ich habe die Installation als Benutzer "michel" gestartet und die Meldung der Benutzerkontensteuerung bestätigt. Wie bei jeder Installation. Vielleicht hat anbuva als Administrator installiert??

Zum Mutex: Er heißt "Spamihilator" :-) Zum Beenden suchst du nach dem Fenster "Spamihilator" und sendest WM_CLOSE.

Gruß
Michel

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 14:17
von dme

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 16:05
von dme

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 17:10
von Chactory

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 17:13
von Chactory

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 18:11
von anbuva

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 22:30
von dme
Hallo anbuva,

ich habe mit dem IMP-Filter weitergemacht, warte aber mir der Herausgabe des Updates ab, ob sich bzgl. des Installers hier noch was ergibt. Gibt es denn überhaupt einen Plugin-Installer der wirklich richtig unter Vista funktioniert? Und gibt es dafür nicht eine Vorlage?

Gruß
Detlef

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 23:11
von anbuva
Hallo dme!

Die PlugIns, die unter Vista (und den Benutzern in Vista) funktionieren, findest Du in meiner FAQ. Die spezifischen Einstellungen bzw. Pfade wurden immer korrekt im Benutzerverzeichnis angelegt.

Im Moment bin ich jedoch irretiert, da Michel ja mitteilte, dass es bei ihm funktionieren würde; daher ja auch meine letzten Fragen.

Kann es angehen, dass hier vielleicht noch eine weitere "Routine" fehlt? Bei der Installation scheint ja alles korrekt abzulaufen und die Daten werden ja auch grundsätzlich richtig erstellt. Müsste es aber nicht so nach dem Start des Spami (und damit auch des PlugIns) so aussehen, dass das PlugIn im Verzeichnis eines neuen Benutzers (wo die Daten noch nicht stehen) diese Daten neu anlegen müsste; liegt hier also das Problem, dass die Dateien nur bei der Installation angelegt werden und danach nicht mehr? Als normalem Benutzer bleibt einem ja das Verzeichnis vom Admin verschlossen. Wenn aber ein Benutzer mit den nötigen Rechten ausgestattet ist, gibt es hier dann ja auch keine Schwierigkeiten und die Anzeige der Daten erfolgt (auch über das PlugIn) korrekt.

@Michel: Wie sieht es aus, wenn Du einen neuen Benutzer erstellst und diesem nur die eingeschränkten (vom System her) Rechte gibst? Bei mir hat es mit einem neuen Benutzer jedenfalls auch nicht funktioniert.

Wird also nach dem Start vom Spami bzw. des PlugIns eine Abfrage gestartet, ob die Daten vorhanden sind und falls nein, dann neu erstellt...?
Hier liegt m. M. nach das Problem, da bei dem Benutzer das PlugIn normal mitgestartet wird und durch die manuelle Kopieraktion ja sonst auch prima funktioniert.

Gruß
anbuva

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 12. Jan 2009, 23:47
von dme

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 13. Jan 2009, 00:05
von anbuva
Hallo dme!

Grundsätzlich kann man aber ja erstmal sagen, dass der Filter funktioniert.

(Ich gehe mal im weiteren Text davon aus, dass ich nicht alleine mit der Pfadproblematik und den fehlenden Daten stehe :wink: )
Lässt sich hier denn vielleicht nicht fürs erste ein Mittelweg finden, dass die generellen Daten mitsamt der Hilfedatei erstmal ins Verzeichnis von der Installation (C:\Program....\Spami...) kopiert werden und der User die Projektdaten selber anlegen und die Pfade vorgeben muss (so wie ich es mit dem Kopieren schon getan habe)? Das hat ja auch funktioniert und wäre ja auch nicht weiter schlimm....
Das Problem mit den spezifischen Pfaden kann man dann ja noch später lösen; hauptsache der Filter funktioniert erstmal :D ...

Gruß
anbuva

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 13. Jan 2009, 07:28
von Andreas_Z
Hallo anbuva!

Sag mal, hast Du Deine Vista-Rechner in einer Domäne oder die UAC abgeschaltet? Unter umständen hast Du ja Deinem Userkonto die Gruppenmitgliedschaft "Administratoren" aberkannt. Oder gar eine Kombination davon. Wie Du es beschreibst wird der Trustedinstaller nicht angestoßen, wenn eine Setuproutine gestartet wird.

Gruß
Andreas_Z

Re: Language file, Filterungsgrund, Etikette

BeitragVerfasst: 13. Jan 2009, 08:10
von anbuva
Hallo Andreas_Z!

Kann ich ausschließen; keine Domäne, UAC ein. Bei allen anderen Programmen funktioniert es sonst auch. So werden bei mir andere Programme, welche administrative Eingaben oder Installationen benötigen, auch mit der entsprechende Aufforderung gestartet. Bei den anderen PlugIns/Filtern funktioniert es ja auch; nur eben hier nicht. Spaßeshalber habe ich noch einen neuen User-Account erstellt, mit demselben Ergebnis.

Ich möchte desweiteren auch noch mal auf meine letzten Postings verweisen; da es hier ja nur um die Daten geht, welche ich als Benutzer rüberkopieren muss, damit es dann trotzdem funktioniert. Das liegt m. A. nach schon ursächlich in der Installation begründet. Im Klartext: Beim User wird das PlugIn angezeigt und ist funktionsfähig; es fehlen halt nur die Daten bzw. der Pfad dorthin.

Hast Du es denn auch mit Vista und einem eingeschränkten Benutzer ausprobiert?

Gruß
anbuva