Kein Icon im Infobereich mit Spami2Service unter Vista

Alles, was mit Plugins für Spamihilator zu tun hat. (Keine Plugin-Hilfe, Plugin-Bugs oder Plugin Feature Requests, siehe jeweils dort.)

Moderator: Forum-Team

Re: Kein Icon im Infobereich mit Spami2Service unter Vista

Beitragvon WebAdd » 29. Jun 2008, 12:37

Hallo Michel!

brigens ist schnelle Benutzerumschaltung durchaus auch ohne Dienst möglich. Spamihilator kann mehrfach unter verschiedenen Benutzerkonten gestartet werden.

Das kann ich leider bei mir nicht bestätigen. Folgendes habe ich gestern auf meinem WinXP-PC durchgeführt (unter Vista habe ich genau das gleiche Problem).

1. Versuch:
  • da ich bisher Spami2Service unter WinXP benutzt habe, wurde der Dienst von mir (als Administrator) unter Verwaltung | Dienste beendet und deaktiviert
  • nun habe ich über das Startmenü den Spamihilator gestartet und unter den allg. Einstellungen den Haken für den Windowsstart gesetzt
  • der PC wurde anschließend neu gestartet
  • als erstes habe ich mich als Administrator angemeldet; Spamihilator wird im Systray sehr schön angezeigt und ich konnte z.B. das Einstellungsfenster öffnen :)
  • nun habe ich mich über Start | Abmelden | Benutzer wechseln als ein User der normalen Benutzergruppe angemeldet
  • Spamihilator versucht zu starten (Icon mit Sanduhr) und es erscheint nach einer Weile eine Meldung von Spami, dass das Programm einen Fehlerbericht angelegt hat
  • das Icon mit der Sanduhr verschwindet wieder (kein Icon von Spami im Systray) und Spamihilator kann unter dem zuletzt angemeldeten User nicht genutzt werden :(
  • die durch Spami angelegte *.dmp-Datei wurde gesichert
  • nun habe ich mich als User der normalen Benutzergruppe wieder abgemeldet (Start | Abmelden | Abmelden)
  • das PW des noch angemeldeten Administrators wieder eingegeben, um zu sehen ob der Spamihilator noch funktioniert :)

  • Ergebnis von Versuch 1: Eine schnelle Benutzerumschaltung ist nicht möglich.

    Versuch 2:
    Der folgende Versuch wurde hauptsächlich ausgeführt, um eventuell fehlende Schreibrechte auszuschließen.
  • Unter HKLM\Software\Spamihilator den Wert ConfigDir von 1 auf 0 geändert (beim Versuch 1 stand dieser Wert auf 1)
  • PC wurde nun neu gestartet
  • diesmal habe ich mich erst als User der normalen Benutzergruppe (selbes Login wie bei Versuch 1) angemeldet; der Spamihilator wurde erfolgreich gestartet :)
  • nun wurde die schnelle Benutzerumschaltung (Start | Abmelden | Benutzer wechseln) zum Administrator Login durchgeführt
  • Spmi bringt die gleiche Fehlermeldung auch unter dem Administrator zur Anzeige, wie zuvor unter dem Versuch 1 (an dieser Stelle kann ein eventuell fehlendes Schreibrecht ausgeschlossen werden, da der Administrator überall Vollzugriff hat) :(
  • die *.dmp-Datei habe ich auch von diesem Versuch gesichert

  • Ergebnis von Versuch 2: Eine schnelle Benutzerumschaltung ist nicht möglich.

    Hat noch einer eine Idee?
    Michel kann ich Dir die beiden DMP-Dateien direkt oder soll ich diese an die angegebene E-Mail-Adresse der Fehlermeldung senden?

    Gruß
    WebAdd
    WebAdd
    Power-User
    Power-User
     
    Beiträge: 10
    Registriert: 22. Jun 2008, 13:06

    Re: Kein Icon im Infobereich mit Spami2Service unter Vista

    Beitragvon michel » 29. Jun 2008, 16:20

    Hi!

    Vielen Dank für deine Versuche!

    pamihilator versucht zu starten (Icon mit Sanduhr) und es erscheint nach einer Weile eine Meldung von Spami, dass das Programm einen Fehlerbericht angelegt hat

    Das sollte eigentlich nicht passieren. Wahrscheinlich war das mit "Unterstützung für schnelle Benutzerumschaltung verbessern" in der TODO-Liste gemeint ;-)

    ichel kann ich Dir die beiden DMP-Dateien direkt oder soll ich diese an die angegebene E-Mail-Adresse der Fehlermeldung senden?

    Das ist egal. Bitte verwende einen aussagekräftigen Betreff und am besten einen kurzen Text in der Mail, damit ich die .dmp-Datei korrekt zuordnen kann. Danke.

    Gruß
    Michel
    Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
    Benutzeravatar
    michel
    Administrator
    Administrator
     
    Administration
    Beta-Tester
    Forum-Team
    Plugin-Programmierer
     
    Beiträge: 4335
    Registriert: 22. Mär 2003, 01:16
    Wohnort: Buseck
    Nach oben

    Vorherige

    Zurück zu Plugins: Allgemein

    Wer ist online?

    Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

    cron

     industrious-southeast