Seite 3 von 4

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 16:31
von anbuva
Hallo AlexV!

Sorry that I had forgotten. Now comes over the "private channel" :wink: .

Regards
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 17:01
von AlexV
OK, got it. The email address looks like this:
Code: Alles auswählen
Name Name [mailto:example@googlemail.com]

Can you check if that's the way it actually appears in the header (look at the mail in Spamihilator, and check the "Show full message including headers" checkbox, then look for the line starting "To:".

If that is the case, then the reason Misnamed Filter can't learn from it is that it is not a valid email address format (according to rfc2822 or the updated 5322) - email addresses, where paired with display names, must appear within < >, not within [ ], and do not include a "mailto:" prefix (ref).

I'm surprised that it manages to be routed to you with an address in the format, I would be interested to know what actually generated the email.

Regards,

Alex

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 17:43
von anbuva
Hallo AlexV!

to me it looks quite correct. Also with other accounts. So that's in the header:
to: example@mail.de
Just for fun, I've also taken an account that had various names before and a new name created (same ..@... adress). This new name will not be learned.
Could it be that the filter has problems with the latest versions of Spamihilator?

bei mir sieht das ganz korrekt aus. Ebenfalls mit anderen Konten. Also so im Header:
to: example@mail.de
Spaßeshalber habe ich auch mal ein Konto genommen, was schon diverse Namen hatte und einen neuen Namen (gleiche Adresse) erstellt. Dieser neue Name wird nicht mehr gelernt.
Könnte es auch sein, dass der Filter Probleme mit den letzten Versionen vom Spamihilator hat?

Regards
Gruß
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 18:02
von AlexV
Hi anbuva!

If the header is:
Code: Alles auswählen
to: example@mail.de

Then there is no name, so it can't be added.

If the header is:
Code: Alles auswählen
to: Name Name [mailto:example@googlemail.com]

Then it is not valid, and can't be added.

If it is one of:
Code: Alles auswählen
to: "Name Name" <example@googlemail.com>
to: 'Name Name' <example@googlemail.com>
to: Name Name <example@googlemail.com>

Then it should be working, and I have not been able to figure out any reason why it wouldn't from your settings file. I am using Spamihilator 0.9.9.53 - are you using a newer beta?

Regards,
AlexV

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 18:45
von anbuva
Hallo AlexV!

thank you. Version 0.9.9.58 (beta).

@an alle anderen:
Bitte mal testen, wie das bei euch aussieht; gerade bei älteren Spamihilator-Versionen.

Gruß
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 19:24
von AlexV
Hi anbuva!

That explains it, then. I've just tried installing 0.9.9.58, and my plugin no longer gets the learning notification from Spamihilator! It looks like a bug with Spamihilator, but I will have to try and find release notes or a changelog to see if there is something new that plugins have to do to allow them to learn now.

--

Ich habe jetz schon mit 0.9.9.58 versucht, und ja, es funktioniert nicht. Meine plugin bekommt keine meldung(?) von Spamihilator zu dem Email lernen. Ich wies noch nicht warum, ob ich muss etwas anderen im Plugin, oder sonst eine Spamililator-fehler ist.

Regards,
AlexV

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 13. Mär 2011, 20:07
von anbuva
Hallo AlexV!

great :) , because we are already a big step further. :wink:

@michel (falls Du das liest): vielleicht kannst Du hier auch noch etwas beitragen :)

Regards
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 14. Mär 2011, 20:49
von Antispammer
Hi AlexV,

as I did not understand what this ".name" should be
AlexV hat geschrieben:alex -at- vallat -dot- name


I wrote you a private forum message, that includes tested details to one of the problems with the filter (name decoding doesn't work).
Please look into your private messages inbox.

Thanks in advance,
Antispammer

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 14. Mär 2011, 21:13
von AlexV
I have been a bit blind, and not noticed the "0.3" in the thread title. Decoding support was only added in v0.4, and the latest version is 0.5. The thread for this plugin is here, and the latest version can be downloaded from there. Sorry for the confusion!

The .name is literally ".name". Not as common a TLD as .com, but it is a valid email address.

Regards,

Alex Vallat

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 14. Mär 2011, 21:22
von Antispammer
Anybody out there who can update the link to version 0.3 on
http://www.spamihilator.com/plugins?category=1&start=0&limit=15

Code: Alles auswählen
Misnamed Filter   Stimmen
04.05.2007, 581 KB, 57593 Downloads
von Alex Vallat

This plugin’s purpose is to detect spam emails which have been sent to valid email addresses, but… [mehr]

Herunterladen (http://www.byalexv.co.uk/spamihilator/MisnamedFilter-0.3.exe)

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 14. Mär 2011, 21:53
von anbuva
Hallo AlexV!

0.3... I was too :oops: . But I have the latest versions (both, filter 0.5 and Spamihilator beta) and the problem is also here.

Regards
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 14. Mär 2011, 21:57
von anbuva
Hallo Antispammer!

danke für den Hinweis. Das sollte in die Version 0.5 geändert werden. Ich habe schon Bescheid gegeben. :)

Gruß
anbuva

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 15. Mär 2011, 07:41
von Andreas_Z
Hallo anbuva!

Ich antworte mal kurz in Deutsch (Mein Englisch reicht grad zum lesen). Ich hatte auch die 0.3 im Einsatz. Hab gerade die letzte Version installiert. Ich muß im laufe des Tages mal testen.

Gruß
Andreas_Z

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 3. Apr 2011, 11:04
von michel
Hi!

AlexV asked me to check if the latest beta version of Spamihilator still sends the SERV_LEARN message. This message is sent in order to let a plugin learn from a message. I just checked that. The message is indeed sent. By the way, the plugin returns 1 (TRUE) in response to this message.

I then checked the configuration of the Misnamed Filter and the mail address I just learned from was not added. I think there must be something wrong inside the plugin. It also seems this is independent from a specific Spamihilator version, since this thread is actually about 0.9.9.53 and not only about the latest beta version.

@AlexV: If you need some more help in debugging, just let me know!

Bye,
Michel

Re: Misnamed Filter 0.3 & Spami 0.9.9.53?

BeitragVerfasst: 3. Apr 2011, 11:06
von michel
Antispammer hat geschrieben:Anybody out there who can update the link to version 0.3 on
http://www.spamihilator.com/plugins?category=1&start=0&limit=15

I just updated that page. Thanks!

Bye,
Michel