Newsletter-Filter funktioniert nicht

Haben Sie einen Fehler in einem Plugin entdeckt?

Moderator: Forum-Team

Newsletter-Filter funktioniert nicht

Beitragvon tlu » 13. Mai 2006, 09:45

Hallo alle miteinander!

Den Spami verwende ich schon seit längerer Zeit, im Forum habe ich auch schon des öfteren mitgelesen, aber noch nie gepostet. Heute ist es so weit - daher einen herzlichen Gruß an alle!

Nun zu meinem Problem: Ich hatte die EOS .19 ausprobiert, war aber wegen der kleinen Probleme (die ja auch im entsprechenden Forum diskutiert wurden) zur .13 zurück gekehrt (ganz neu aufgesetzt). Hier habe ich nun zum ersten mal das Problem, dass Newsletter, die ich ordnungsgemäß in den an erster Stelle stehenden Newletter-Filter eingetragen habe, trotzdem z.B vom Adressee- oder vom Spamwort-Filter als Spam klassifiziert werden.

Wie gesagt: Ich hatte dieses Proble noch nie. Leider habe ich im Forum nichts darüber finden können. Hat irgend jemand von euch eine Idee, woran es liegen könnte?

Gruß

Thomas
Benutzeravatar
tlu
Spam-Killer
Spam-Killer
 
Beiträge: 31
Registriert: 13. Mai 2006, 09:32

Re: Newsletter-Filter funktioniert nicht

Beitragvon anbuva » 13. Mai 2006, 12:15

Hallo tlu!

Hast Du mal Deine Filter-Reihenfolge überprüft? Könnte sein, dass Deine Reihenfolge nicht mehr stimmt, gerade wenn Du sagst "neu installiert", wird es wahrscheinlich auch so sein. Spami gibt nämlich nicht eine bestimmte Reihenfolge der Filter vor, dieses musst Du noch selber erledigen!

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Newsletter-Filter funktioniert nicht

Beitragvon tlu » 14. Mai 2006, 04:30

anbuva hat geschrieben:Hallo tlu!

Hast Du mal Deine Filter-Reihenfolge überprüft? Könnte sein, dass Deine Reihenfolge nicht mehr stimmt, gerade wenn Du sagst "neu installiert", wird es wahrscheinlich auch so sein. Spami gibt nämlich nicht eine bestimmte Reihenfolge der Filter vor, dieses musst Du noch selber erledigen!


Hallo anbuva,

die Reihenfolge stimmt - der Newsletter-Filter steht an erster Stelle. Wie gesagt: Ich verwende den Spami schon recht lang, und das war natürlich so ziemlich das erste, was ich eingestellt habe. Ich habe übrigens gerade die .13 noch mal darüber installiert, es hat sich aber nichts geändert. :cry:

Gruß

Thomas
Benutzeravatar
tlu
Spam-Killer
Spam-Killer
 
Beiträge: 31
Registriert: 13. Mai 2006, 09:32

Re: Newsletter-Filter funktioniert nicht

Beitragvon Chactory » 14. Mai 2006, 12:32

Hi Thomas, hi Anbuva,

bitte poste doch mal den Eintrag im Newsletter-Plugin und den Header des Newsletters.
Typischer Fehler N°1: Man soll ja den Empfänger in die Liste eintragen, nicht den Absender. Fehler N°2: Manche Newsletter-Versender ändern ihre Angaben.

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Newsletter-Filter funktioniert nicht

Beitragvon anbuva » 14. Mai 2006, 20:20

Chactory hat geschrieben:Fehler N°2: Manche Newsletter-Versender ändern ihre Angaben.


Oh, da kann ich ein Lied von singen: Ich hatte mal so einen wahnsinnigen Versender von (gewollten) Newsletter, der jede Woche seine Angaben änderte und meine Regeln durcheinanderbrachte. Habe deshalb schon eine andere Lösung finden können.

Schönen Abend noch

anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Newsletter-Filter funktioniert nicht

Beitragvon tlu » 14. Mai 2006, 23:11

Chactory hat geschrieben:Typischer Fehler N°1: Man soll ja den Empfänger in die Liste eintragen, nicht den Absender.


Aargh - das war's! Ich Schussel hatte tatsächlich einige falsche Einträge eingepflegt - peinlich, peinlich ... :oops: Aber natürlich vielen Dank für den Hinweis! Wer weiß, wie lange ich noch herumgerätselt hätte, ohne über das Offensichtliche zu stolpern.

Gruß

Thomas
Benutzeravatar
tlu
Spam-Killer
Spam-Killer
 
Beiträge: 31
Registriert: 13. Mai 2006, 09:32

Re: Newsletter-Filter funktioniert nicht

Beitragvon nemesiz » 5. Mär 2007, 14:16

Chactory hat geschrieben:Hi Thomas, hi Anbuva,

bitte poste doch mal den Eintrag im Newsletter-Plugin und den Header des Newsletters.
Typischer Fehler N°1: Man soll ja den Empfänger in die Liste eintragen, nicht den Absender. Fehler N°2: Manche Newsletter-Versender ändern ihre Angaben.

Gruß, Chactory


kann mir das nun mal jemand erklären?

ich bekomme einen newsletter von saturn.

news@saturn.de ... sodele
und was trag ich nun wie und wo ein?
Benutzeravatar
nemesiz
Spam-Massenmörder
Spam-Massenmörder
 
Beiträge: 109
Registriert: 25. Feb 2007, 18:20
Wohnort: Mannheim

Re: Newsletter-Filter funktioniert nicht

Beitragvon Quellcore » 5. Mär 2007, 14:35

Hallo nemesiz!

Es gibt 3 Merkmale, an denen man Newsletter erkennen könnte:

  • Eine gleichbleibende Phrase im Betreff der Mail
  • Immer die gleiche Empfängeradresse, aber NICHT Deine eigene Mailadresse (Stichwort Newsgroups)
  • Immer die gleiche Absender-Adresse

Michel, der Programmierer des Spamihilators und des Newsletter-Plugins, hat es leider nicht vorgesehen, Newsletter mit immer der gleichen Absender-Adresse mit dem Newsletter-Plugin zu erkennen.
Dafür muß man dann andere Filter wie den Whitestring-Filter oder die Freundesliste mißbrauchen.
Hauptproblem der Würgarounds mit anderen Filtern ist die Tatsache. daß man den lernenden Filter von Newslettern nicht unbedingt als Non-Spam lernen lassen sollte, da diese spamtypische Merkmale aufweisen. (Das hiermal lesen)

Auf eine erweiterte Version des Newsletter-Plugins werden wir wohl noch einige Zeit warten müssen, d Michel den Spami gerade komplett neu schreibt und solche Projekte dann ganz hinten an stehen.

Gruß
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: Newsletter-Filter funktioniert nicht

Beitragvon nemesiz » 5. Mär 2007, 14:42

Hallo Quellcore!


ah, also komme ich mit der eingabe von news@saturn. nicht weiter..

seh ich da nun also richtig. kein wunder dass da immer alles als spam erkannt wird.
(sind halt meis images)


Gruß
nemesiz
Benutzeravatar
nemesiz
Spam-Massenmörder
Spam-Massenmörder
 
Beiträge: 109
Registriert: 25. Feb 2007, 18:20
Wohnort: Mannheim

Re: Newsletter-Filter funktioniert nicht

Beitragvon Quellcore » 5. Mär 2007, 14:54

Hallo nemesiz!

Schau Dir mal die Betreffzeile genauer an, evtl. kommst Du damit weiter!
Ansonsten mußt Du halt die von mir genannten Ausweichmöglichkeiten in Betracht ziehen, den Whitestring-Filter oder die Freundesliste zu benutzen.

Gruß
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: Newsletter-Filter funktioniert nicht

Beitragvon Chactory » 5. Mär 2007, 15:07

Hallo nemesiz und Quellcore,

inzwischen spiele ich mit dem Gedanken, meine in der Freundesliste eingetragenen Newsletter-Absender dort wieder zu löschen. Ich möchte sie stattdessen lieber mit Betreff in die Signaturenliste oder mit der Empfängerkennung in die Newsgroupsliste in das Newsletter-Plugin eintragen. Allerdings habe ich tatsächlich Probleme, weil manche Newsletter wechselnde Betreffs haben oder keine Newsgroup als Empfänger angeben.
Ich hoffe deshalb, daß Michel Krämer in der neuen Spamihilatorversion auch den ansich sehr intelligenten Newsletter-Filter noch mit einer Absender-Liste ergänzt.
Bisher verwende ich die Freundeliste nämlich eigentlich nicht korrekt. Ich wollte dies bisher absichtlich nie, damit sich Spamihilator aus eigener Filterleistung bewähren muß, und ich habe trotzdem eine recht gute (geringe) Rate falsch-positiver Filterungen.

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)


Zurück zu Plugins: Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

 industrious-southeast