Fehler im Signature-Filter?

Haben Sie einen Fehler in einem Plugin entdeckt?

Moderator: Forum-Team

Re: Fehler im Signature-Filter?

Beitragvon Chactory » 7. Nov 2004, 18:47

Oh, ja, klar ... :oops: Vielen Dank!
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 14. Nov 2004, 22:18

Hi Bernhard,

I will try the new version and see what happens. :-)

Thanks,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 20. Nov 2004, 09:16

Hi BillyX,

Maybe I am misunderstanding what the filter is supposed to do, or I didn't explain the problem well.

I got an e-mail today that was marked as Spam by the Signature filter. It's header information is below. (I changed my e-mail address to xxx@xxx.xxx for security reasons.)

Code: Alles auswählen
Return-Path: <strawberry@emo.com>
Delivered-To: bobl@0
Received: (qmail 16438 invoked from network); 19 Nov 2004 22:10:01 -0000
Received: from unknown (HELO pool-141-158-107-80.pitt.east.verizon.net) (141.158.107.80)
    by 226.69-93-48.reverse.theplanet.com with SMTP; 19 Nov 2004 22:10:01 -0000
Subject: Personal Wealth of Information
Message-ID: <AWDAnd4Q4.vQMbhHMmNI3@hallow7.emophilips.com>
From: "Foster Benton" <strawberry@emo.com>
To: "Foster Benton" <strawberry@emo.com>
Cc:  xxx@xxx.xxx
Date: Fri, 19 Nov 2004 20:57:12 -0100
MIME-Version: 1.0
Content-Type: multipart/alternative;
   boundary="--3_WGWTvp8W0.pHUkrVZwHV8"


I don't understand why the Signature filter would consider this Spam (even though it really was a Spam). My e-mail address is not in the "From" field. Is that not what the Signature filter is looking at?

Regards,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 20. Nov 2004, 15:47

Ok, this seems to be a bug in the filter.

If your adress wouldn't be in the cc or bcc part, the filter would correctly assume
-that you must be "Foster Benton" and you have sent the mail to yourself and there must be therefor your signature
-the mail is spam and the sender faked

The filter already checks for multiple reciepients but not it they are one in cc ard one in to.
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 22. Nov 2004, 01:01

Ahhhh, ok. I thought the filter only looked at the From address and the message body. For example, if my e-mail address is in the From address and my signature was not in the message body, it would be a Spam. Thanks for the explanation.

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon Gast » 21. Jun 2007, 10:44

Guten Tag!
Sorry, dass ich diesen alten Thread hervorkrame aber bei mir hat der Signature-Filter ein Email als Spam markiert, in der ich weder im FROM noch CC oder BCC stehe.

Code: Alles auswählen
Received: from unknown ([172.18.5.228])
            by mailbox08.aon.at (qmail-ldap-1.03) with QMQP; 21 Jun 2007 08:17:21 -0000
Delivered-To: CLUSTERHOST smarthub75.highway.telekom.at thomas.*****@aon.at
Received: (qmail 2074 invoked from network); 21 Jun 2007 08:17:20 -0000
Received: from host42.host42.com ([80.64.130.113])
            (envelope-sender <office@avaloop.com>)
            by smarthub75.highway.telekom.at (qmail-ldap-1.03) with SMTP
            for <thomas.*****@aon.at>; 21 Jun 2007 08:17:20 -0000
Received: from mx.inode.at (mx04.lb01.inode.at [62.99.145.4])
   by host42.host42.com (8.13.6/8.13.6) with ESMTP id l5L8HFpL031194
   for <pia@*****.at>; Thu, 21 Jun 2007 10:17:20 +0200
Message-Id: <200706210817.l5L8HFpL031194@host42.host42.com>
Received: from [62.178.138.8] (port=15009 helo=Martin)
   by smartmx-04.inode.at with esmtpa (Exim 4.50)
   id 1I1Hqi-0006t6-PU; Thu, 21 Jun 2007 10:17:04 +0200
From: "Office Avaloop" <office@avaloop.com>
To: <office@avaloop.com>
Subject: Neues von Papermint
Date: Thu, 21 Jun 2007 10:16:30 +0200
MIME-Version: 1.0
Content-Type: multipart/related;
   boundary="----=_NextPart_000_0021_01C7B3ED.4706AF70"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3138
Thread-Index: AceymYe2AniQp0xvR36ZlLAKldqpSwAABSnAACcFQPAAAJj9wAAAJNEwAA
BimjAAAEu34AAALnRgAAAnDkAAAHziIAAAFcOwAAAPOSAAAE9oQAAAa1a
gAAAINhAAAAhcwAAACJ9QAAKAnTAAABYRYAAAGBMQAAAGssAAAAqbAA
AAMYoAAAAQiWAAAFo9wAAAGSogAAARbUAAABnBMAAADmuAAAAn01AA
ACCOkAAItHVAABmixGAAAB2gkAAACNqw
X-Antivirus: avast! (VPS 000751-1, 20.06.2007), Inbound message
X-Antivirus-Status: Clean


Als Signatur hab ich "Thomas *****" eingestellt und die Checkbox "Mails from me..." ist aktiviert.

Gibt es dazu Erfahrungen?


Gruß
Thomas
Gast
 

Re: Fehler im Signature-Filter?

Beitragvon Quellcore » 21. Jun 2007, 11:07

Anonymous hat geschrieben:Sorry, dass ich diesen alten Thread hervorkrame aber bei mir hat der Signature-Filter ein Email als Spam markiert, in der ich weder im FROM noch CC oder BCC stehe.
...
Als Signatur hab ich "Thomas *****" eingestellt und die Checkbox "Mails from me..." ist aktiviert.

Wer sagt denn, daß Deine Mail-Adresse drin stehen muß :?:
Der Signature-Filter kennt doch Deine Adressen gar nicht.

Auf der vorherigen Seite hat BillyX es auch noch einmal erklärt:
BillyX hat geschrieben:Die Bedingung ist ziemlich einfach: Es gibt nur einen Empfänger und der ist gleichzeitig der Absender.

Wenn dann die von dir eingetragene Signatur fehlt, dann ist es Spam.
Zumdinestens wenn du die entsprechende Option in den Einstellungen des Filters aktivierst.

Gruß,
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: Fehler im Signature-Filter?

Beitragvon Gast » 21. Jun 2007, 17:35

Hallo Quellcore!

Vielen Dank für die Antwort. Scheinbar hab ich den Filter komplett falsch verstanden und verwendet :oops: .

Gruß
Thomas
Gast
 

Vorherige

Zurück zu Plugins: Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

 industrious-southeast