Fehler im Signature-Filter?

Haben Sie einen Fehler in einem Plugin entdeckt?

Moderator: Forum-Team

Fehler im Signature-Filter?

Beitragvon Gast » 14. Nov 2003, 17:05

Ich habe den Signatur-Filter mit der Option "Mails from me without my signature are spam" laufen. Da ich öfters Spam mit meiner eigenen Adresse als Absender bekomme, finde ich diese Option recht praktisch.

Jetzt habe ich heute eine Email bekommen (kein Spam, die Mail kam von S3bast1an, es ging um den neuen Beta-URL-Filter), in der ich als Adressat nur unter BCC aufgeführt war. Diese Email wurde vom Signatur-Filter als Spam aussortiert und ich habe sie nur durch Zufall im Papierkorb gefunden.

Ist das ein Fehler im Signaturfilter?

Florian
Gast
 

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 17. Nov 2003, 18:51

Das ist seltsam... Kannst du mir genaueres über die Felder From, Reciever, Reply-To, To, CC und BCC schreiben?
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Florian » 19. Nov 2003, 18:28

Der Fehler im Signature-Plugin ist heute wieder aufgetreten. Und das obwohl ich die Spamerkennungsfunktion des Plugins abgeschalten habe (es sollte eigentlich nur noch Nicht-Spam erkennen). Trotzdem hat es drei Emails in den Papierkorb befördert. Nach welchen Kriterien es das getan hat, ist mir schleierhaft. Keine der Emails hatte meine Adresse als Absender (ausserdem hatte ich ja diese Option abgeschaltet). Zum Glück waren es tatsächlich Spams.
Florian
Florian
Spam-Terminator
Spam-Terminator
 
Beiträge: 52
Registriert: 18. Nov 2003, 14:38

Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 6. Dez 2003, 06:05

Hi Bernhard,

I was reading some of the messages on the forum (using the German to English translator on AltaVista.com) and saw this thread. It sounds like the problem I was having. The e-mail wasn't directly to me, but my e-mail address was in the CC: or BCC: field. Have you done any testing like that? If you would like to test this, you can send me some e-mails with my e-mail address in the CC: and BCC: fields (and no text in the message body). I still haven't received any more of those messages that cause the problem, but it's possible I cleared up the problem when I disabled the Signature plugin when I was testing my plugin. I have since enabled the Signature plugin and am waiting for it to happen again.

Tschuess,

Bob Loeffler
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 6. Dez 2003, 06:23

There could be a problem (a fact I didn't have think about) in my algorithm to detect spam-mails sent with the own mail adress as sender but I havn't got an example (with the adresses in FROM, TO, CC, and BCC) yet so I couldn't think about it yet.
There is a problem in the filter if the filter is running for a few days with beeing restarted. It happens then that the filter treates from on point of time every mail as spam. This must be a memoryleak or something like that but I wasn't able to find the problem yet.

Bernhard

PS: If you answer at one thread every person who has written in this thread gets an notification if it was not turned off.
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 6. Dez 2003, 06:59

Just as I was reading your message here on the forum, I received 4 e-mails that caused the problem! :-) It looks like it's the "X-Rcpt-To:" field (and maybe other fields as we suggested earlier). All 4 of the e-mails have my e-mail address in this header field. I am pasting one of the e-mail headers here:

Return-Path: <crouch_xs@azzit.de>
Received: from atlasvanlines.ca ([67.167.253.55]) by ; Fri, 05 Dec 2003 23:04:37 -0600
Message-ID: <GGFKNCCBMKEGFCAOFFHAGMFKHKAA.crouch_xs@azzit.de>
From: "Sherman Crouch" <crouch_xs@azzit.de>
To: bobl@peaktopeak.com
Subject: paris hilton p0rn 4free
Date: Sat, 06 Dec 2003 05:12:10 +0000
MIME-Version: 1.0
Content-Type: text/html
Content-Transfer-Encoding: base64
X-Rcpt-To: <bobl@peaktopeak.com>
X-DPOP: Version number supressed
X-UIDL: 1070687469.1118
Status: U
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon Gustl » 17. Okt 2004, 09:31

Has the Problem with the Signature Filter been resolved? If it would be working, then it seems to be the better solution than the signature work around in the whitestring filter.
I love the smell of polyurethane in the morning | http://www.vgwebdesign.com
Benutzeravatar
Gustl
Spam-Massenmörder
Spam-Massenmörder
 
Beiträge: 153
Registriert: 10. Okt 2004, 17:11
Wohnort: Tief im Westen, wo die Sonne verstaubt

Re: Fehler im Signature-Filter?

Beitragvon Bob Loeffler » 7. Nov 2004, 05:23

Hi Gustl,

As far as I know, it hasn't been fixed yet.

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 7. Nov 2004, 11:42

As far as I know there was no bug ;-)
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Chactory » 7. Nov 2004, 15:54

Hallo BillyX,

bisher habe ich das berichtete Problem bei mir noch nicht beobachtet. Bei mir steht der Filter an erster Stelle in der Reihenfolge der Filter, mit den Optionen - wenn Spam, dann mit dem nächsten Filter fortfahren - wenn NON-Spam, beende den Filterprozess.
Kann mir interessehalber mal jemand eine solche Mail, wie oben beschrieben, zusenden?
Was meinst Du mit "afaik there was no bug"? Ist das Problem durch etwas anderes verursacht?
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 7. Nov 2004, 16:27

Hallo Chactory!

Ich hab das angesprochene Problem auch noch nicht festgestellt, allerdings hatte ich ein anderes Problem das oben beschrieben war. Das Problem könnte allerdings auch von Spami selbst gekommen sein und inzwischen behoben sein.

Meine Vermutung zu dem von anderen angesprochenen Problem war das es vielleicht das gleiche Problem war das ich hatte, weil das Beispielmail bei mir keine Probleme machte.

Ich hab den Code nochmal durchgeschaut und eine kleine Unsauberkeit korrigiert. Die neue Version stelle ich online.

Gruß
BillyX
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Chactory » 7. Nov 2004, 16:53

Hi BillyX,

Florian verwendet vermutlich noch die letzte veröffentlichte Programmversion, aber Bob müßte die Betaversion einsetzen. Somit scheint das Problem noch aktuell zu sein? Komisch, daß das Problem bei einigen auftritt, bei anderen nicht, also welche Konstellation hat Bob z.B.?

Prima, daß Du die erwähnte Unsauberkeit im Code verbessert hast. Wenn Du schon dabei bist ... wie wäre es mit einer Überarbeitung Deines Filters im Sinne von http://www.spamihilator.com/forum/viewt ... 0070#20070 ? :wink:
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 7. Nov 2004, 17:01

Hallo Chactory!

Wir sprechen hier von einem Problem das ich zuletzt in Version 0.9.7 und dann auch erst nach einigen Tagen Laufzeit beobachtet habe weil ich seither Spami nicht mehr verwende ;-)

Stelle die Einstellung mal auf bei Spam Erkennung beenden.

Gruß
BillyX
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Re: Fehler im Signature-Filter?

Beitragvon Chactory » 7. Nov 2004, 17:44

Hallo BillyX,

was muß ich da hören? :wink: Ich habe kürzlich einmal die Website Cute Connections besucht, blicke aber nicht durch ... Verwendet man die dort genannten Programme parallel, also z.B. die POP3- und SMTP-Versionen?

Bisher hatte ich den Signaturfilter nur als Negativ-Filter verwendet, also zum Erkennen und Filtern "guter" bzw. "Non-Spam-" Mail. Deshalb habe ich die Einstellungen bewußt nicht auf "bei Spam-Erkennung beenden" gestellt. Als Negativfilter kann Signature auch gut an erster Stelle in der Reihenfolge stehen, weil er klein und schnell ist und ziemlich viele Prozesse schon bei ihm enden, da ich viele E-Mail-Antworten erhalte.

Ich verzichte dafür auf die Eigenschaft, daß der Signature-Filter Spam-Mails herausfischen kann, die vorgeben, von mir zu stammen, aber eben meine Signatur nicht tragen. Ich verstehe aber auch nicht, wie der Signature-Filter eine Mail "from me" definiert, hier wäre die von mir oben nochmals angeregte bessere Dokumentation hilfreich. Ich verwende mehr als nur einen E-Mail-Account. Erschwerend kommt noch hinzu, daß ich auch nicht in allen E-Mails immer meine Signatur eintrage.

Somit kommt mir diese Positiv-Filterfunktion eher unsicher vor. Vielleicht liegt also der von Florian und Bob gefundene Fehler gar nicht in der Programmierung, sondern in den zugrundeliegenden Bedingungen?
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Fehler im Signature-Filter?

Beitragvon BillyX » 7. Nov 2004, 18:18

Hallo Chactory!

Die Bedingung ist ziemlich einfach: Es gibt nur einen Empfänger und der ist gleichzeitig der Absender.

Von Florian hab ich kein Beispiel eines Mails bekommen das abgefangen wurde, das Beispiel von Bob wird bei mir nicht abgefangen. Ich hab deshalb vermutet das es ein anderes mysteriöses Verhalten ist, vorallem wenn der Filter wie bei Florian sogar im deaktivierten Zustand Mails rausfischt (darauf hab ich keinen Einfluss, da scheint Spami irgendwie zu spinnen)

Gruß
BillyX
Die Redenden wissen nicht viel - Die Wissenden reden nicht viel!
http://www.CuteConnections.Com
Spam these adresses: SpamCatcher@CuteConnections.Com Delete@CuteConnections.Com Recycle@BillyX.com Muell@BillyX.com
BillyX
Fast schon ein Mitarbeiter
Fast schon ein Mitarbeiter
 
Plugin-Programmierer
 
Beiträge: 409
Registriert: 16. Mai 2003, 17:51
Wohnort: Linz

Nächste

Zurück zu Plugins: Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

 industrious-southeast