Mails werden doppelt abgerufen...

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Mails werden doppelt abgerufen...

Beitragvon larifaribummbumm » 16. Jan 2013, 20:55

Hallo Leutz,

bei der aktuellen Version habe ich alle paar Tage folgendes Problem:

Abrufen der neuen Mails-kein Problem.

Nach 30 Minuten automatisches, erneutes Abrufen (neuer Mails)- nun kommen neue, ungelesene Mails und alte Mails von vor 2-4 Wochen.

Ich habe die Funktion:
"Behalte Nachrichten nicht länger als 30 Tage"
und
"Lasse Spammails auf dem Server, bis sie aus dem Papierkorb gelöscht wurden"
eingeschaltet.

Doppelt abgerufen werden die Mails immer von einem bestimmten Tag.
Heute z.B. die vom 29.12.2012.
Es macht für mich den Eindruck, dass die Mails nicht "als bereits abgerufen" markiert wurden.
Ein Künstler ist jemand, der aus der Lösung ein Rätsel machen kann.
larifaribummbumm
Assistent
Assistent
 
Beiträge: 696
Registriert: 3. Okt 2012, 14:40

Re: Mails werden doppelt abgerufen...

Beitragvon Chactory » 18. Jan 2013, 23:36

Hallo larifaribummbumm!

Das ist ja schräge ... wie kommt das zustande ... :wink: *kopfkratz*

Bitte gib uns nochmal ein paar Details über den Hintergrund der Installation und die vorgenommenen manuellen Eingriffe in Spamihilator oder den Mail-Client.

Sicherheitshalber noch gefragt, werden die Mails von mehreren Computern oder Geräten abgerufen?

Könntest Du uns mal einen Screenshot oder einen Header zeigen? Und Ausschnitte aus der client.log und der server.log?

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Mails werden doppelt abgerufen...

Beitragvon anbuva » 19. Jan 2013, 10:50

Hallo larifaribummbumm!

lässt sich der "bestimmte Tag" irgendwie besser beschreiben (so in der Art wie immer genau 2 Wochen vorher)?

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Mails werden doppelt abgerufen...

Beitragvon larifaribummbumm » 19. Jan 2013, 21:30

Hallo,

also ich habe etliche Mailkonten, werden über einen PC abgerufen.
Ich habe eben wieder welche bekommen, die ich schon abgerufen habe.
Das war in diesem Fall vor 11 Tagen.

Ich rufe Mails ab, Spam lösche ich direkt in Spamihilator, die werden dann also beim Nächsten abrufen auf dem Server gelöscht.

Meine "guten" Mails bleiben für 30 Tage auf dem Server.

Ich habe nun festgestellt, dass die "guten" Mails auf dem Server nicht immer als "Gelesen" makiert werden.
Das scheint der Grund zu sein, warum sie nochmal abgerufen werden.
Allerdings verstehe ich nicht, warum das teilweise erst nach sovielen Tagen passiert.
Es kommt aber auch vor, das "wie zu erwarten wäre" die Mails beim nächsten Mal abrufen nochmal geladen werden.

Wer nimmt die "gelesen Makierung" vor?
Spamihilator oder das Email Programm?

Ich tippe mal auf Spamihilator !?
Ein Künstler ist jemand, der aus der Lösung ein Rätsel machen kann.
larifaribummbumm
Assistent
Assistent
 
Beiträge: 696
Registriert: 3. Okt 2012, 14:40

Re: Mails werden doppelt abgerufen...

Beitragvon Andreas_Z » 21. Jan 2013, 08:03

Hallo larifaribummbumm!

Die Markierung nimmt der Client vor. Der sendet Sie an Spami der sie wiederrum an den Server weiter reicht. Warum das mal geht und mal nicht kann ich nicht sagen. Wenn Mails eines bestimmen Tages immer wieder auftauchen, würde ich auf ein Problem mit dem UID-Cache von Spami tippen. Denn kann man von Hand leeren. Dann erkennt Spami zwar alle Mails als neu, dafür hast Du aber wieder einen Stand. Bitte suche mal hier im Forum danach.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Mails werden doppelt abgerufen...

Beitragvon anbuva » 21. Jan 2013, 12:11

Hallo zusammen!

@Andreas_Z: Super Tipp!
...und den Link dorthin auch gleich für andere mal posten. Ich habe den jetzt auf die Schnelle nicht finden können :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Mails werden doppelt abgerufen...

Beitragvon Chactory » 22. Jan 2013, 19:45

Hi zusammen!

Ich fände es gut, wenn Lari einmal detailliert seine betroffenen Mailkonten durchsehen und deren Eigenschaften vergleichen würde (nebst den von mir oben angesprochenen Recherchen :wink:).

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Mails werden doppelt abgerufen...

Beitragvon larifaribummbumm » 23. Jan 2013, 20:31

Hallo,

also ich habe die radikale Methode genommen.
-Alles deinstalliert, neu aufgesetzt-

Der Grund dafür ist, das ich das schon lange vor hatte. Seit Jahren habe ich immer nur aktualisiert und überinstalliert, nun wollte ich alles mal "sauber" haben.
Gibt es Deinstaller für die Plugins? Ich habe Spamihilator deinstalliert und den Rest manuell gelöscht.

Installiert habe ich die aktuelle Spamihilator Version, den Regelfilter, Statistik, Export Sender, Spam Wort Filter und lernender Filter.

Was ich aus der alten Installation übernommen habe:
Blockierte (11.000) und Freunde (1.000) Adressen und den lernenden Filter.

Lange Zeit ging bei der Kombination von Avast/ Mail Filter Plugin zu Spamihilator.
Avast klinkt sich in den Mailversand ein und kontrolliert Ein- und Ausgänge.
Soweit ok, nur: Avast will/ soll über SSL arbeiten, daher muss in Spamihilator die Option
"Aktiviere SSL/TLS automatisch..." deaktiviert werden.

Nun geht alles!

*freu*
Ein Künstler ist jemand, der aus der Lösung ein Rätsel machen kann.
larifaribummbumm
Assistent
Assistent
 
Beiträge: 696
Registriert: 3. Okt 2012, 14:40

Re: Mails werden doppelt abgerufen...

Beitragvon Chactory » 23. Jan 2013, 20:53

Hallo larifaribummbumm!

Das ist natürlich auch eine gute Idee gewesen! :)
Vielleicht waren einfach zu viele Einstellungen inkompatibel?
Oder Plugins, die nicht mehr mit der aktuellen Betriebssystem-
Software oder mit Spamihilator 1.5.0 zusammen funktionieren?
Export Senders - geht das überhaupt noch?
Könnte man da nicht einfach die ".db"-Datei kopieren?

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Mails werden doppelt abgerufen...

Beitragvon anbuva » 23. Jan 2013, 21:20

Hallo larifaribummbumm!

die Filter besitzen meist eine Deinstallationsroutine. Sofern sie nicht per Hand reinkopiert wurden. Kommt also darauf an, wie der (einzelne) Filter vorher installiert wurden.

Mit avast ist ja interessant. Der scheint sich dann doch stärker als vermutet einzuklinken. Wundert mich eigentlich, dass es so etwas noch gibt. Ich habe Avast auf meinem Zweit-PC, dass muss ich wohl mal selber testen. Bislang ist mir das noch nicht aufgefallen, aber ich nutze den auch so gut wie selten..

Auf jeden Fall freue ich mich, dass Du es alleine hinbiegen konntest :)

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Mails werden doppelt abgerufen...

Beitragvon larifaribummbumm » 24. Jan 2013, 15:55

Hallo Chactory,
Hallo Anbuva,

wie ich sehen konnte, wurden manche Nachrichten auf dem Server einfach nicht als "gelesen" makiert. Warum diese dann nach so vielen Tagen dann nochmal (und nicht schon beim nächsten Mal) einloggen abgerufen wurden, ist mir schleierhaft.

Ich benutze Spamihilator schon seit ganz langer Zeit und habe oft die zusätzlichen Filter installiert und wieder deinstalliert, um zu schauen wir ich die besten Erfolge habe.

Das Mails doppelt angerufen werden, habe ich in der letzten Version auch ab und an mal gehabt, aber erst in der aktuellen Version war sehr häufig. Bei meinem Mailaufkommen schon sehr nervig gewesen.
Mit rund 10 Mailadressen, ca.350 Mails/ Tag, welche Servermäßig untereinander noch verschoben, gefiltert, kopiert und weitergeleitet werden ist das schon schwer den Überblick zu behalten.

Neu ist, das ich seit etwa Weihnachten kaum noch Spam bekomme.
Da muss was bei den Freemailanbietern geändert worden sein (ich erinnere mich daran, dass ein Kumpel etwas an seinem Mailversand ändern musste, da seine Mails sonst bei den Freemailanbietern geblockt wurden), oder da wurden Spamnetze abgeschaltet.

Export Senders , ja geht noch! Allerdings sind irgendwie rund 100 "Freundesadressen" bei der Umstellung verschwunden. Die Anzeige wieviele Adressen sich aktuell in der jeweiligen Liste befinden, deckte sich nicht mit dem Export.

Zu Avast:
Mir ist es erst jetzt aufgefallen, das mit der neuen Version von Spamihilator meine Mails nicht mehr von Avast gescannt wurden. In der aktuellen Version war SSL Verschlüsselung wieder aktiv.

Beim Abrufen der Mails habe ich zeitgleich den Echtzeitmonitor des Mailschutzes von Avast aufgemacht.
Ich hatte das in der letzten Verison schon einmal und dann auch behoben, indem ich die SSL Verschlüsselung von Spamihilator deaktiviert habe.
Somit findet die Verschlüsselung von Avast statt und die ein und ausgehenden Mails werden wieder gescannt. Zudem trägt Avast im unteren Teil der Mails ein, dass sie "Sauber" sind.

Nun klappt wieder alles.
Dank !! Spamihilator !!
Ein Künstler ist jemand, der aus der Lösung ein Rätsel machen kann.
larifaribummbumm
Assistent
Assistent
 
Beiträge: 696
Registriert: 3. Okt 2012, 14:40

Re: Mails werden doppelt abgerufen...

Beitragvon anbuva » 24. Jan 2013, 17:02

Hallo larifaribummbumm!

vielen Dank für Deine ausführliche Rückmeldung. :)
In der Tat verändert Avast die Mail. Ich muss das irgendwann mal genauer ausprobieren, wie sich das auf meinen anderen PC mit anderen Einstellungen weiter darstellt.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Mails werden doppelt abgerufen...

Beitragvon Chactory » 25. Jan 2013, 22:50

Hallo larifaribummbumm, hallo anbuva!

In neuen Spamihilator-Versionen werden die Freunde und die Feinde in einer Datenbankdatei namens senders.db unter C:\Users\user_name\AppData\Roaming\Spamihilator gespeichert. Vielleicht hast Du darum mit dem Export-Senders-Plugin, das noch für die alte spamihilator.ini-Datei programmiert wurde, nur einen Teil Deiner (alten) Listen-Einträge übernehmen können.

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Mails werden doppelt abgerufen...

Beitragvon larifaribummbumm » 26. Jan 2013, 11:18

Hallo,

also ich muss ich mich verbessern, es klappt doch nicht mehr mit dem Export Senders.
"Export Senders" habe ich noch installiert, es erstellt auch die Dateien, aber die sind natürlich leer.

Ich hatte ursprünglich die Einstellungen der alten Version exportiert und zusätzlich manuell gesichert, dann alles deinstalliert und die finale Version installiert. Dann habe ich den Export der Adressen über Export Senders gemacht, wo mit die rund 100 Adressen abhanden kamen..

Dann fiel mir auf, dass ich da noch alte Daten unter "Anwendungsdaten" hatte. Also nochmal alles deinstalliert, manuell gelöscht und die finale Version installiert.

Ich habe die ursprüngliche senders.db dann manuell geöffnet, die Adresen in Excel kopiert, gefiltert und "sauber" über die Importfunktion eingefügt.

Klingt alles sehr chaotisch, aber manchmal geht es daneben, wenn man es "perfekt" haben will.
Mein Leitsatz "Never change a running system" vergesse ich nur zu gerne.
Nun ist aber wirklich wieder alles tutti, alle Adressen sind wieder da.
Danke!
Ein Künstler ist jemand, der aus der Lösung ein Rätsel machen kann.
larifaribummbumm
Assistent
Assistent
 
Beiträge: 696
Registriert: 3. Okt 2012, 14:40

Re: Mails werden doppelt abgerufen...

Beitragvon anbuva » 26. Jan 2013, 12:49

Hallo larifaribummbumm!

wohl wahr. Aber das hat jeder schon mal oder öfter erleben dürfen :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Nächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron

 industrious-southeast