Falsche Headerzuordnung in The Bat!

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 17:28

(Crossposting von batboard.net, dort fragte ich natürlich ebenfalls!)

Ich weiß nicht, ob ich den Bug den Spamihilator- oder den The-Bat!-Entwicklern melden soll:

Ich nutze ja zurzeit, bis ich eine bessere Alternative finde, Spamihilator als Spamwächter für die Mailkonten, auf denen kein SpamAssassin läuft (noch verwende ich einige externe Maildienste neben meinen eigenen). Heute Vormittag ist es mir passiert, dass Spamihilator eine von drei eingehenden Mails weggefiltert hat. So weit nicht ungewöhnlich. The Bat! war davon allerdings anscheinend etwas verwirrt, denn es wies plötzlich Kopfzeilen falsch zu. Eine der eingehenden Mails erhielt plötzlich die Kopfzeilen einer anderen Mail, die (zu Recht) in einen Unterordner sortiert worden war, auch die andere enthielt nicht den gewünschten Inhalt. Ein Neustart brachte keine Verbesserung.

Wodurch kann derlei passieren?
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon anbuva » 19. Okt 2012, 17:54

Hallo Cthulhux!

da ich Dein Mailprogramm nicht weiter kenne und den Spami dafür jahrelang umso besser, würde ich die Ursache beim Mailprogramm oder auch Maildienst zuerst vermuten und gehe daher nicht von einem Bug aus (was nicht heißen soll, dass ich es kategorisch ausschließen würde). Von so einem Verhalten habe ich noch nie gelesen oder gehört. Ist mir also momentan völlig neu. Mit anderen Worten: Er muss ja eine Mail mit einer anderen verknüpft haben. Aber ich kann mir nicht vorstellen, wie das ganze abgelaufen sein soll oder das gehen sollte. Ich denke mal, dass man vom Ablauf her die ganze Kette (vom Eingang Server bis zur Ansicht im Mailprogramm) genauer unter die Lupe nehmen müsste.
Dein Doppelposting war insofern ok, da man beide Seiten hören sollte. Vielleicht postet Du mal Deinen Beitrag von dort bzw. den Link dazu.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 18:15

anbuva hat geschrieben:da ich Dein Mailprogramm nicht weiter kenne und den Spami dafür jahrelang umso besser, würde ich die Ursache beim Mailprogramm oder auch Maildienst zuerst vermuten

Im Forum des Mailprogramms berichtete man Gegenteiliges. Wer hat nun Recht?

anbuva hat geschrieben:Von so einem Verhalten habe ich noch nie gelesen oder gehört.

Geht mir leider auch so...!

anbuva hat geschrieben:Vielleicht postet Du mal Deinen Beitrag von dort bzw. den Link dazu.

Wollte ich, aber das Forum sagt, ich darf keine Links setzen.
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 18:15

Ah, nun habe ich wohl genug Beiträge hier:

http://www.batboard.net/board4-informat ... m-konzept/
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon anbuva » 19. Okt 2012, 19:20

Hallo Cthulhux!

danke für den Link. Auf jeden Fall haben wir so auch ein paar Infos mehr. Auf jeden Fall gut, dass Du dort gepostet hast. Als Doppelpost sehe ich das jedenfalls nicht.

Da ich letztendlich auch nichts davon halte, nun gegenseitig oder nur bei einen die Schuld zu suchen, versuche ich lieber beide Seiten einzubeziehen. Letztendlich wäre es damit im Moment auch egal, wer da nun eigentlich patzt oder gepatzt hat. Wichtig wäre es jetzt also, hier eine Lösung für Dich zu finden.

Das Verhalten hat sich bislang aber noch nicht wieder gezeigt? Habe ich das richtig gelesen? Das wäre dann natürlich umso schwieriger.

The Bat, IMAP sind Sachen, mit denen ich mich ehrlich gesagt gesamt gesehen nicht so gut auskenne. Ich kann hier im Moment nur auf andere warten, die hier vielleicht weiter ansetzen können. Über alles andere könnte ich jetzt nur spekulieren.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 19:25

Bisher ist das nur einmal aufgetreten. Vielleicht mag Spamihilator die Sortierfunktionen von The Bat! nicht?
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon anbuva » 19. Okt 2012, 19:28

Hallo Cthulhux!

Spamihilator holt bei POP z. B. ja eigentlich nur ab, prüft und übergibt. IMAP ist natürlich etwas anders. Wie muss man sich das Sortieren denn bei The Bat vorstellen? Vergreift sich The Bat auch an Mails, die gerade bearbeitet werden?

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 19:56

The Bat! kategorisiert Filter in vier Gruppen: Eingehende Mails, ausgehende Mails, gelesene Nachrichten, beantwortete Nachrichten. Der Filter, der hier greift, ist der für eingehende Mails. So weit ich das verstanden habe, spielt Spamihilator doch hier aber ohnehin den lokalen IMAP-Server, so dass The Bat! die Spam-Mails überhaupt nicht zu Gesicht bekommt?
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon anbuva » 19. Okt 2012, 20:12

Hallo Cthulhux!

die Gruppen sind eigentlich normal und so kenne ich das auch. Die Mails werden vom Programm verwaltet. So kenne ich das von Outlook und IMAP. Spami schaltet sich nur bei der Überprüfung der Emails dazwischen. IMAP war aber immer schon irgendwie problematisch. Selbst unter Outlook 2010 bin ich wieder zu POP übergegangen, da Outlook manchmal die Mails einfach nicht abholen wollte. Selbst gesendete wollte er mir manchmal nicht anzeigen.

Tja, wie gesagt, ich muss mal abwarten, was andere Experten hier noch beitragen können. Das Hauptproblem ist eigentlich im Moment eher, dass wir das Problem nicht reproduzieren können, was dann weiterhelfen könnte.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 19. Okt 2012, 20:16

POP3 ist unpraktisch. Ich verwalte meine Mails auch vom Smartphone aus, da wäre POP3 quasi tödlich.

Hmpf, dann warten wir mal ab ...
(Ich stellte die Frage nebenbei auch auf der The-Bat!-Mailingliste. Mal gucken, ob es funktioniert.)
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon anbuva » 19. Okt 2012, 20:26

Hallo Cthulhux!

in der Tat. Das ist vielleicht ein "Nachteil" von POP. Kann ich dann verstehen.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Chactory » 3. Nov 2012, 13:27

Ich wollte mal nachlesen, ob sich ergeben hat, daß letztlich hoffentlich doch die Beta von The Bat! für das seltsame Phänomen verantwortlich ist, konnte jedoch im The Bat! Forum keine weiteren Beiträge dazu finden.

Off topic: Ich mag übrigens IMAP genauso wenig, wie ich das Arbeiten in der Cloud mag. Auch wenn ich mich damit wieder mal als lebenden Anachronismus oute, ich habe es doch gerne alles bei mir auf dem Notebook, und hasse die Schwierigkeiten, die man zusätzlich bekommt, wenn man wieder trotz zeitaufwendiger Mühen keine Internetverbindung herstellen oder organisieren kann ...
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 3. Nov 2012, 13:37

Ist noch nicht wieder aufgetreten - allerdings hab' ich den Spamihilator vorerst wieder rausgeworfen, bis mir jemand 'ne Lösung anbietet. :)
Zumal er anscheinend "als gelesen markiert" nicht korrekt verarbeitet hat - es waren immer "ungelesene Mails" im Posteingang, wtf. Das Phänomen ist verschwunden, seit ich den Spamihilator nicht mehr dazwischen geschaltet habe.

Ja, ich bin mir der datenschutztechnischen Nachteile von IMAP bewusst. Allerdings habe ich vollen Einblick in das, was der von mir hauptsächlich benutzte Mailserver so tut. - Und POP3 ist keine Lösung, da ich ein Smartphone verwende und auch dort gelegentlich E-Mail nutzen möchte. ;) - IMAP im Offline-Modus funktioniert übrigens hervorragend.
Cthulhux
 

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Chactory » 3. Nov 2012, 15:03

Cthulhux hat geschrieben:Zumal [Spamihilator] anscheinend "als gelesen markiert" nicht korrekt verarbeitet hat - es waren immer "ungelesene Mails" im Posteingang, wtf.
Ich muß wohl doch mal interessehalber zur Probe The Bat! installieren ... ;)
Ist The Bat! ein regelkonformes und problemlos deinstallierbares Programm?

Cthulhux hat geschrieben:IMAP im Offline-Modus funktioniert übrigens hervorragend.
Vielleicht besteht mein Hauptproblem mit IMAP ja auch in Wirklichkeit darin, daß ich im Job mit Lotus Notes arbeiten muß - und ich kann Dir nur sagen, das nervt wahnsinnig, weil IBM alles anders machen muß, als Microsoft, und dieses Mailprogramm hölzern und unfertig wirkt, und ich damit leider nicht offline arbeiten kann ... argh! :evil:
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Falsche Headerzuordnung in The Bat!

Beitragvon Cthulhux » 3. Nov 2012, 15:10

Chactory hat geschrieben:Ich muß wohl doch mal interessehalber zur Probe The Bat! installieren ... ;)

Ich kann dich nur warnen: Du wirst nicht davon loskommen. Geiles Teil, das. :mrgreen:
(Ja, ich bin restlos überzeugt.)

Chactory hat geschrieben:Ist The Bat! ein regelkonformes und problemlos deinstallierbares Programm?

"Regelkonform"? Malware ist es nicht. :)
Deinstallation hab' ich bisher nicht versucht, sollte ich? ;)

Chactory hat geschrieben:Vielleicht besteht mein Hauptproblem mit IMAP ja auch in Wirklichkeit darin, daß ich im Job mit Lotus Notes arbeiten muß

Oh, spitze. Hatte ich mir um die Jahrtausendwende herum mal angesehen, ich fand die Bedienung furchtbar. Ist das immer noch so?
Cthulhux
 

Nächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

 industrious-southeast