Wiederherstellung geht nicht (bei einer Mail)

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Apr 2012, 21:08

Hallo Chactory!

so habe ich das verstanden.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Apr 2012, 21:51

Hallo Anbuva!

Danke! :) Dann verstehe ich es jetzt auch (teilweise ;)).

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Apr 2012, 21:53

Hallo Chactory!

:)

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Skeptiker » 22. Apr 2012, 22:04

Ich bringe mal etwas mehr Licht in die Sache.

Das Problem kam so zu Stande:

Ursprünglich wurde das Freenet-Konto vom Heimserver abgerufen, dort läuft Spami hinter dem Janaserver.

Da das meine "Ramschadresse" ist, mit der ich mich wenn nötig mal hier und da usw. registriere, kommt dort auch viel Spam rein. Nun hab ich die Adresse vom Jana weggenommen und hole die Freenet-Mails meist mit dem Arbeits-PC, manchmal auch mit dem Laptop ab.

Es kam dazu, dass ich beim Einrichten auf dem Arbeitsplatzrechner beim Loginnamen dieses "@freenet.de" drin hatte, da das funktionierte fiel es nicht auf. Im PO3-Notifier stand die Adresse dank copy & paste aber ohne "@freenet.de" drin.

POP3-Notifier hat dann die Mails in der Form "pop3.freenet.de&Benutzername" abgefragt und der Mailclient hat mit "pop3.freenet.de&Benutzername@freenet.de" abholen wollen.

Wenn ich Michel richtig verstanden hab, ordnet Spami intern die Mails den Logindaten entsprechend zu. Geht eine Mail in den Papierkorb, kann sie nach der Wiederherstellung, entsprechend den zugeordneten Logindaten, eben nur mit diesen wieder ausgeliefert werden.

"pop3.freenet.de&Benutzername@freenet.de" ist für Spami eben etwas anderes als "pop3.freenet.de&Benutzername".

Und wenn man dann, so wie es mir passiert ist, zur Fehlersuche ein weiteres Programm wie POPTray nimmt und da die korrekten Daten drin hat, bekommt POPTray die Mail, der Mailclient aber nicht. Stellt sich dann noch die Frage warum ich von Freenet mit beiden Formen des Benutzernamen die Mails abholen kann, wahrscheinlich ist der Mailserver dort tolleranter als Spami.


Dabei ist mir noch etwas aufgefallen:
Habe auf 7x64 gewechselt und dort funktioniert der bei den Addons zu ladende PO3-Notifier 0.3.3 nicht. Hier im Forum ist PO3-Notifier 1.0 verlinkt der super funktioniert.
Wird dieser bei den Addons dann auch verlinkt werden?
Skeptiker
Power-User
Power-User
 
Beiträge: 8
Registriert: 18. Dez 2011, 10:30

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Apr 2012, 22:14

Hallo Skeptiker!

der Mailserver kennt eben beide (auf dem Server sind beide Varianten quasi miteinander verknüpft), Spamihilator kennt nur die eine Adresse vom ersten Abholen her. Daher mein Gedanke, dass Spami unabhängig vom Konto die Mails aus dem Papierkorb beim Abholen zustellt; also wirklich ohne Zuordnung eines Kontos. Das würde in Richtung toleranter gehen. Ich weiß jetzt allerdings nicht, ob so etwas machbar wäre oder es hier noch andere Probleme geben kann. Das einzige was ich mir vorstellen könnte wäre, dass es mehrere Benutzer gibt und ein Benutzer B auf einmal die Mails vom Benutzer A ohne Berechtigungsprüfung bekommt, da Spami einfach ausliefert. Durch getrennte Benutzerkonten sollte das mittlerweile aber kein Problem mehr darstellen.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Apr 2012, 22:16

Hallo Skeptiker!

Erstmal vielen Dank für Deine Beschreibungen! So langsam sickert auch bei mir ein, wie das alles zustandekam. :mrgreen:

Vielen Dank nochmals an Anbuva für Deine Erläuterungen. :)

Ich hoffe, daß Anbuva Dir bei Deiner Frage etwas weiterhelfen kann.

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Skeptiker » 23. Apr 2012, 08:58

anbuva hat geschrieben:... mein Gedanke, dass Spami unabhängig vom Konto die Mails aus dem Papierkorb beim Abholen zustellt; also wirklich ohne Zuordnung eines Kontos. Das würde in Richtung toleranter gehen. Ich weiß jetzt allerdings nicht, ob so etwas machbar wäre oder es hier noch andere Probleme geben kann. Das einzige was ich mir vorstellen könnte wäre, dass es mehrere Benutzer gibt und ein Benutzer B auf einmal die Mails vom Benutzer A ohne Berechtigungsprüfung bekommt, da Spami einfach ausliefert. Durch getrennte Benutzerkonten sollte das mittlerweile aber kein Problem mehr darstellen.



Das wird so eher nicht machbar sein. Was wird mit den Leuten, die den Spami auf einem Server betreiben (Spami läuft bei mir vor JanaServer)? An welche Mailadresse soll Spami dann ausliefern?
Au Mann wär das'n Ding, wenn meine Frau die Mails von meiner Ex zugestellt bekäme :shock: :lol:
Da helfen dann auch keine Benutzerkonten.

Was ich mir vorstellen könnte, wäre optional eine administrative Mailadresse festlegen zu können an die Spami dann Fehlermeldungen usw. sendet. Man könnte dann die im JanaServer für diese Zwecke festgelegte interne Mailadresse nehmen, was sich wunderbar ergänzen würde.

Gruß
Skepti
Skeptiker
Power-User
Power-User
 
Beiträge: 8
Registriert: 18. Dez 2011, 10:30

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 23. Apr 2012, 10:00

Hallo Skeptiker!

vielleicht eine Option in Art von:

Wiederherstellung aus dem Papierkorb:
o Liefere Mails immer an den abrufenden Client aus
o Liefere Mails nur an das entsprechende Konto aus

Die Logik wäre noch zu überprüfen.

Das dürfte nur relativ gering vorkommen, dass man so eine Möglichkeit unbedingt braucht, würde aber doch so manchen Ärger ersparen.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Skeptiker » 23. Apr 2012, 11:25

Hallo anbuva!

Im Prinzip gibt es das mit dem entfernen der Kontoinformationen schon.
Nach entfernen der Kontoinformationen konnten die hängen gebliebenen Mails abgeholt werden, der Mailclient war Spami dabei egal.
Eventuell könnte diese Funktion mit der Möglichkeit hängende Mails an ein auswählbares Mailkonto zuzustellen erweitert werden.
Dazu ist Michels Meinung gefragt.

Gruß
Skeptiker
Skeptiker
Power-User
Power-User
 
Beiträge: 8
Registriert: 18. Dez 2011, 10:30

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 23. Apr 2012, 18:07

Hallo Skeptiker!

ja, warten wir mal auf eine Antwort (hoffe, dass michel hier mitliest) :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Andreas_Z » 24. Apr 2012, 07:10

Hallo Skeptiker!

Ich habe hier mal mitgelesen und möchte mal noch eine Frage stellen. Wurden tatsächlich einige Mails nicht im Papierkorb angezeigt? Denn selbst wenn man die Konto-Infos verändert und ein Abholen ohne das Entfernen der Kontoinfos nicht mehr möglich ist, Spammails sollte immer dort landen. Die einzigen Mails, die nicht sichtbar sind, sind Non-Spam-Mails. Die liegen im Cache bis sie abgeholt werden. Die kann man nur kurz im Trainigsbereich sehen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Skeptiker » 24. Apr 2012, 09:38

Hallo Andreas_Z!

Es ging darum, dass Mails im Papierkorb blieben und nach Wiederherstellung nicht abgeholt werden konnten, sie wurden dort auch angezeigt.


Gruß
Skeptiker
Skeptiker
Power-User
Power-User
 
Beiträge: 8
Registriert: 18. Dez 2011, 10:30

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Andreas_Z » 25. Apr 2012, 06:48

Hallo Skeptiker!

Ahhh ok. Oder besser nicht OK. Diesen Fehler hatten wir hier schon mal. Ich dachte aber, Michel hätte den schon behoben.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Vorherige

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron

 industrious-southeast