Wiederherstellung geht nicht (bei einer Mail)

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Andreas_Z » 22. Dez 2011, 10:17

Hallo Chactory!

Das Mails nicht abgeholt werden können, kann verschiedene Ursachen haben. In den letzten Wochen haben aber verschiedene User herausgefunden, dass dieses Vorgehen hilft. Eine genaue Erklärung habe ich auch nicht. Aber möglicherweise hat Spami irgendwo noch einen Bug, der dafür sorgt, dass Mails manchmal nicht sauber zugestellt werden. Da ja Spami die Mails immer an das zugehörige Konto ausliefert, muß es passende Infos zu speichern. Irgendwo hier würde ich den Fehler suchen. Wenn man die Konto-Infos entfernt, können Mails von jedem Konto abgeholt werden. Wahrscheinlich wird die Fehlerhafte Stelle auf diese Weise umgangen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Dez 2011, 19:34

Hallo Andreas_Z!

wenn es sich um keine Einzelfälle handelt, dann muss man das wohl mal genauer angehen.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Dez 2011, 23:22

Hallo Andreas_Z und Anbuva!

Vielen Dank für Eure Antworten! :)

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Dez 2011, 23:50

Hallo Chactory!

jetzt wäre wohl michel gefragt....

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Andreas_Z » 24. Dez 2011, 08:42

Hallo anbuva!

Ja. Leider läßt sich das Problem nicht provozieren. Ich würde das gern mal nachstellen. Aber mir geht alles. Allerdings habe ich so wie nichts wiederherzustellen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 24. Dez 2011, 11:01

Hallo Andreas_Z!

ich kenne das Problem selber auch nicht.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon michel » 24. Dez 2011, 11:37

Hi!

Ein Bug in Spamihilator ist es nicht. Ich nehme eher an, dass es entweder ein Bug in einem bestimmten E-Mail-Programm oder ein falsch konfiguriertes Konto oder - wie Skeptiker bereits richtig gesagt hat - ein falscher E-Mail-Header ist. Es gibt also viele Ursachen und deshalb wurde diese Funktion schon in einer sehr frühen Version von Spamihilator eingebaut.

Zur weiteren Erklärung: Eine Mail bleibt immer dann im Papierkorb "hängen", wenn die Verbindungsinformationen, die Spamihilator vom E-Mail-Programm bekommen hat, beim ersten Mail-Abruf nicht mit denen übereinstimmen, die bei allen weiteren Abrufen genutzt werden. Beispiel: Das E-Mail-Programm fragt den Server "pop.gmx.de" mit dem Benutzernamen "ein_gmx_benutzer" ab. Dabei wird eine E-Mail in den Papierkorb "geworfen". Bei allen folgenden Abrufen benutzt das Mail-Programm aber plötzlich "mail.gmx.de" oder z.B. die IP-Adresse. Dadurch kann keine korrekte Zuordnung mehr getroffen werden (Spamihilator weiß nicht, in welches Konto die Mail wiederhergestellt werden soll) und die Mail bleibt immer im Papierkorb.

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 24. Dez 2011, 11:59

Hallo michel!

das erklärt es jetzt wohl recht gut. :)

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 25. Dez 2011, 12:22

Hallo allerseits!

Danke für Deine Erläuterungen, Michel! :)

Diese "Entferne Kontoinformationen"-Funktion ist also auch nützlich, wenn etwa zwischen Empfang und Wiederherstellen etwas am Mailkonto verändert wurde.

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Skeptiker » 22. Apr 2012, 19:04

Hallo

Michel hat mir die Augen geöffnet, vielen Dank.

Nachdem alles eine ganze Weile so funktionierte wie es sollte und kürzlich praktisch jede Mail im Papierkorb hängen blieb hatte ich genug Material zum "üben".

Des Rätsels Lösung kam von Michel....

Bei dem Mailkonto handelt es sich um eine Freenetadresse.
Abgeholt wurden die Mails mit dem Eintrag "pop3.freenet.de&Benutzername@freenet.de"
Das funktionierte so wunderbar und ist auch das Problem.
Mit dem Eintrag "pop3.freenet.de&Benutzername", ohne @freenet.de werden die Mails genauso gut abgeholt und bleiben nicht im Papierkorb hängen.
Skeptiker
Power-User
Power-User
 
Beiträge: 8
Registriert: 18. Dez 2011, 10:30

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Apr 2012, 19:26

Hallo Skeptiker!

Freut mich! :)

(Habe aber im Gegensatz zu Dir Michels Erläuterung nicht so gut verstanden, daß ich Deine Lösung verstünde ...)

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Apr 2012, 19:37

Hallo Chactory!

das habe ich jetzt aber mal verstanden :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Apr 2012, 19:49

Hallo Anbuva!

:lol:

Dann hilf mir bitte! :?

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon anbuva » 22. Apr 2012, 20:18

Hallo Chactory!

was michel meint (so habe ich es verstanden und wäre auch für mich nachzuvollziehen) ist, dass das die Konto-Information im Mailprogramm von dem User (oder auch einem anderen Programm) geändert wurde (warum auch immer das so passierte).
Die Wiederherstellung einer Mail im Papierkorb klappt aber nur mit den Informationen, mit denen vorher die Mail abgerufen und in den Papierkorb gelegt wurde. Spamihilator weiß ja nicht, dass XYZ@Mail.de auch unter 123@Mail.de zu erreichen ist. So kann ich z. B. mich mit einer Kundennummer oder auch einer Mailadresse beim Provider anmelden. Für die Wiederherstellung ist es aber wichtig, ob die Kundennummer oder die Mailadresse vorher zum Einsatz kam. Die Wiederherstellung wartet also auf die "alte bekannte Adresse". Hier muss also die Adresse exakt der vorherigen vom ersten Aufruf entsprechen.

Vielleicht könnte man eine Wiederherstellung unabhängig davon entwickeln. Ich denke mal an eine Situation wie, dass Provider xyz plötzlich nicht mehr vorhanden ist und eine Mail aber noch im Papierkorb liegt. Die Mail sollte also immer beim Zugriff auf Spami zugestellt werden; eine Art Spami-Konto. Spami müsste ein Abruf auf sich selber starten. Wie das technisch zu lösen wäre, kann ich nicht beantworten.

Ich hoffe ich konnte helfen.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Wiederherstellung geht nicht (bei einer Mail)

Beitragvon Chactory » 22. Apr 2012, 20:36

Hallo anbuva!

Vielen Dank für Deine hilfreiche Erklärung. Ich verstehe aber noch nicht: Hatte denn der User Skeptiker eine solche Änderung vorgenommen?

Gruß,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

VorherigeNächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron

 industrious-southeast