Ver. 1.0 Einstellungen importieren funktioniert nicht

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Re: Ver. 1.0 Einstellungen importieren funktioniert nicht

Beitragvon grommel » 5. Jan 2012, 11:21

ja - aber bei mir hatte ich ja von einer auf 1.0.0er udgedateten Version auf meinem alten WIN XP Rechner auf meinen neuen WIN 7 Rechner mit neu installiertem 1.0.0 importieren wollen. Das sollte ja kein Problem sein.

Gruß
grommel
grommel
User
User
 
Beiträge: 3
Registriert: 2. Jan 2012, 15:02

Re: Ver. 1.0 Einstellungen importieren funktioniert nicht

Beitragvon Quellcore » 6. Jan 2012, 00:15

Hallo grommel!
Wie bereits gesagt sehe ich da auch einen Bug:
Quellcore hat geschrieben:Bei einem weiteren Schnelltest ist mir folgender Bug aufgefallen:
Die Spami-eigene Exportfunktion speichert wahrscheinlich seit 0.9.9.54 nicht mehr die Freundesliste und die Liste der Blockierten Absender, da diese ja jetzt in SQLite-Datenbanken statt in der "spamihilator.ini" abgespeichert werden und die Exportfunktion nicht entsprechend angepasst ist.
Ein schnelles Querlesen der Backupdatei in einem normalen Texteditor lässt mich dies zumindestens vermuten.
Es wäre natürlich nett, wenn das noch einmal jmd. testen/bestätigen könnte.

Gruß
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: Ver. 1.0 Einstellungen importieren funktioniert nicht

Beitragvon anbuva » 6. Jan 2012, 11:07

Hallo!

ich stimme hier zu.
Ein Export sollte zudem auch besser in ein allgemein gültiges Format (z. B. eine Textdatei) konvertiert und gelegt werden, damit man aus diesem Format wieder die Daten korrekt in ein evtl. neues Format konvertieren und einlesen kann.

ich komme hier aber noch mal, weil es gerade so schön passt, auf meinen schon vor Zeiten gemachten Vorschlag zurück:
wäre es hier auch nicht simpel, ein einfaches Backup und Einspielen in Form von "Kopiere benötigte Datei X in ein Verzeichnis eigener Wahl" und "Wiedereinspiele Datei X aus dem Verzeichnis eigener Wahl in das benötigte Verzeichnis vom Spamihilator" vorzunehmen? Z. B. könnte man es so schon mal mit der SQL-Datei machen.
Ich mache es bei mir immer so, dass ich das Spami-Hauptverzeichnis und das Spami-Verzeichnis der eigenen Dateien immer über meinen Dateimanager komplett kopiere (quasi ein Image) und bei einer Neuninstallation die benötigten Dateien (oder das komplette Verzeichnis) einfach wieder hineinkopiere. Bislang fahre ich all die Jahre super damit. Die installierte Spami-Version sollte dann natürlich immer zu der kopierten Version passen; gerade wegen der SQL-Datenbank :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Ver. 1.0 Einstellungen importieren funktioniert nicht

Beitragvon michel » 28. Jan 2012, 15:09

Hi!

Sehr gute Idee. Siehe auch mein Beitrag:
viewtopic.php?f=2&t=8666&p=61310#p61310

Vielleicht können wir in dem anderen Thread weiter diskutieren.

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Ver. 1.0 Einstellungen importieren funktioniert nicht

Beitragvon anbuva » 28. Jan 2012, 15:24

Hallo michel!

jetzt auch gesehen. Machen wir also da weiter (hatte ja dort gerade schon was geschrieben). Gut, dass wir uns da aber einig sind :D Ich hoffe, die anderen sehen das ähnlich.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Vorherige

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

 industrious-southeast