V1.0 - Kleinigkeiten & Fragen

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

V1.0 - Kleinigkeiten & Fragen

Beitragvon Antispammer » 13. Nov 2011, 10:51

Hallo Michel,

danke für die 1.0!!!

Hier ein kleines Feedback:

2 Mini-Bugs hab ich gefunden:

1.
- öffne Papierkorb
- Rechtsklick auf Symbolleiste
- Auswahl Symbole unten
- Rechtsklick auf Symbolleiste
- Auswahl Symbole rechts
-> Eine leere Symbolleiste wird angezeigt (die wenn man das Fenster neu anzeigt wieder weg ist)


2.
- Öffne Einstellungen - Allgemeine Einstellungen - Taskleisteninfobereich
-> Der Text "Zeige die Menge der ..." endet auf "Sekunden (-1 =" Da fehlt irgendwas :)



Dann hab ich noch 3 Fragen:

1. Wo ist der Dialog zum Filterreihenfolge-testen? Den hab ich trotz intensiver Suche nicht gefunden (*bin blind?* :oops:)

2. Ich wollte das neue Feature im Newsletter-Filter benutzen, dass man auch Absender eingeben kann. Hier wollte ich die Forum-Antwortsmails von michel(at)spamihilator.com eintragen. Da muss man aber auch immer einen Namen dazu eingeben... Die Mails kommen aber ohne Namen... macht das was?

3.. Kann man Regeln im Regelfilter kurzzeitig deaktivieren oder muss man sie komplett löschen, wenn man kurz ohne sie arbeiten will?

Vielen Dank & Grüße,
Der Antispammer
Antispammer
Spam-Killer
Spam-Killer
 
Beiträge: 47
Registriert: 17. Feb 2011, 17:26

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Chactory » 14. Nov 2011, 20:28

Hallo!

Vielen Dank! Sehr interessant!

1. Habe ich nachvollzogen, bei mir (Win7 64bit) genauso.
Warum ist eigentlich die Symbolleiste im Trainingsbereich
dicker/breiter, als im Papierkorb ...

2. Ja, dito:
Einstellungen - Allgemeine Einstellungen - Taskleisteninfobereich

Fragen:

1. Trainingsbereich - Datei - Filter testen ...

2. Ich gebe in einem solchen Fall immer an beiden Stellen
einfach die E-Mail-Adresse ein.

3. Die Regeln können offenbar nicht deaktiviert werden.
Ich erzeuge dann eine zweite Bedingung, die verlangt, daß
der Betreff enthält "DEAKTIVIERT DURCH CHACTORY". :mrgreen:

Viele Grüße,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon anbuva » 14. Nov 2011, 23:18

Hallo zusammen!

zu den Mini-Bugs:

1.
kann ich auch bestätigen

2.
das hängt vermutlich wohl noch mit der festen Fenstergröße zusammen. Hier hätte ich eine frei wählbare Größe (oder ein größeres) favorisiert.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Antispammer » 15. Nov 2011, 19:47

Noch was kleines (Bug):

Markiert man eine Nachricht zum "Wiederherstellen" im Papierkorb, dann ist das Wiederherstellen-Symbol (Gelber Pfeil) nicht sichtbar wenn man diese Mail im Papierkorb selektiert.



Und eine Idee:

Im Trainingsbereich beim Filtertester, sollten die Mails, die von einem Filter "Unbekannte Einstufung" erhalten KEIN Symbol erhalten. So kann man sie besser von den positiv oder negativ erkannten unterscheiden.

Viele Grüße,
Der Antispammer
Antispammer
Spam-Killer
Spam-Killer
 
Beiträge: 47
Registriert: 17. Feb 2011, 17:26

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Andreas_Z » 16. Nov 2011, 07:36

Hallo Antispammer!

Der Vorschlag mit ohne Symbol ist, glaube ich, nicht so gut umzusetzen. So wie es derzeit ist, erhalten Nachrichten immer dann kein Symbol, wenn Sie noch nicht als Spam oder Non-Spam markiert wurden. Das würde zu Verwirrung führen. Unbekannte Einstufung heißt ja nur, dass kein Filter eine definitive Aussage getroffen hat. Daher wird sie als Non-Spam aufgefasst.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon anbuva » 16. Nov 2011, 09:49

Hallo Andreas_Z!

quasi im Zweifel für den Angeklagten :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Antispammer » 16. Nov 2011, 17:12

Andreas_Z hat geschrieben:Hallo Antispammer!

Der Vorschlag mit ohne Symbol ist, glaube ich, nicht so gut umzusetzen. So wie es derzeit ist, erhalten Nachrichten immer dann kein Symbol, wenn Sie noch nicht als Spam oder Non-Spam markiert wurden. Das würde zu Verwirrung führen. Unbekannte Einstufung heißt ja nur, dass kein Filter eine definitive Aussage getroffen hat. Daher wird sie als Non-Spam aufgefasst.

Gruß
Andreas_Z


Mein Vorschlag bezieht sich auf den "Filter Tester" im Trainingsbereich - nicht aud den Papierkorb oder Trainingsbereich.

Da ist "der Filter hat nichts erkannt" (weder Spam noch Non-Spam) durchaus wichtig zu erkennen weil man ja jeden Filter einzeln probieren will.

Der Antispammer
Antispammer
Spam-Killer
Spam-Killer
 
Beiträge: 47
Registriert: 17. Feb 2011, 17:26

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Dudi » 25. Nov 2011, 01:38

Hallo zusammen! :)

Da mir auch ein paar Bugs/Fehler bzw. Fehlverhalten von Spami aufgefallen sind, wollte ich sie hier eigentlich nur informative halber mal posten, aber für eine Lösung wäre auch dankbar:

1. Nach dem Update auf 1.0 habe ich an die 1.000 (!) Spam-E-Mails in Outlook wiedergefunden. Ich musste alle per hand löschen.
(Meine Lösung: Keine Updates mehr machen - aber das ist auch nicht die beste Lösung.)

2. Vor dem Update auf 1.0 war ich höchst zufrieden mit dem Filter. Er erkannte, was sicher in den "Papierkorb" durfte (sprich, was Spam ist) und packte alles andere in den Trainingsbereich (mit entsprechender Markierung). Nach dem Update auf 1.0 muss ich nicht nur regelmäßig den Trainingsbereich aufsuchen, um nicht durchgekommene Mails zu finden, sondern muss auch noch den "Papierkorb" öffnen und dort suchen. Etwas umständlich, wenn man mehrere Dutzend Spammails pro Tag bekommt...
Dudi
 

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Dudi » 25. Nov 2011, 01:39

Oh, und...

Danke!!

(sowie)

Schöne Grüße an Euch alle!!
Dudi
 

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon anbuva » 25. Nov 2011, 09:02

Hallo Dudi!

das klingt etwas ungewöhnlich. Ich denke mal, dass wir hier ein paar mehr Details benötigen. Vielleicht ist beim Update etwas schiefgelaufen. Wie wurde z. B. das Update durchgeführt, auf welchem System, welcher Mailclient, 32bit oder 64bit, welche Version war vorher drauf etc.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Dudi » 25. Nov 2011, 09:45

Da es schon ein paar Wochen her ist, kann ich vermutlich nicht mehr alle Fragen beantworten, aber ich versuche es trotzdem.

Spami bot mir das Update an. Ich nahm es an und bin den Anweisungen gefolgt. Ich meine, ich habe ausnahmsweise auch die Option gewählt, in der Spami alles selber bestimmen kann (Speicherort, Funktionsumfang etc). Normaler nehme ich mir die Zeit und kucke es mir an, aber da Spami immer so gut funktionierte und ich mir sicher war, dass alles ok ist, habe ich ausnahmsweise drauf verzichtet.

Win7 32bit
Outlook 2003

Fehlt noch etwas? :?:
Dudi
 

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Chactory » 27. Nov 2011, 18:44

Hallo Dudi!

Das hört sich alles ziemlich schräge an ... :? Wie auch immer, es könnte sich vielleicht trotz der Automatik um ein Problem im Zusammenhang mit der Installation handeln. Ich hoffe, daß Michel Krämer, der Programmautor, Deinen Bericht liest ...

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon anbuva » 27. Nov 2011, 18:52

Hallo Dudi!

mehr als Chactory kann ich im Moment auch nicht sagen. Ist auf jeden Fall sehr ungewöhnlich.

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon michel » 27. Nov 2011, 19:46

Hallo,

das klingt tatsächlich sehr ungewöhnlich.

Zum ersten Problem: Da dieses Verhalten bisher von keinem anderen Benutzer berichtet wurde, gehe ich von einem Einzelfall aus. Ich kann mir nicht vorstellen, dass du bei einem nächsten Update ein ähnliches Problem hast. Ich kann mich erinnern, dass während der Beta-Tests auch Mails doppelt im Posteingang landeten (auch solche, die schon als Spam markiert wurden). Dieser Fehler wurde daraufhin allerdings behoben. Wenn er jedoch schon in der Version 0.9.9.53 drin war, dann ist das Verhalten erklärbar und sollte ab sofort - wie gesagt - nicht noch einmal auftreten.

Das zweite Problem verstehe ich ehrlich gesagt nicht ganz. An der Benutzerführung hat sich ja gegenüber der Vorgängerversion nichts verändert. Kannst du ein bisschen mehr dazu sagen, was jetzt anders ist als vorher?

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: V1.0 - Kleinigkeiten & Fragen

Beitragvon Dudi » 28. Nov 2011, 18:16

Danke nochmals für Eure Antworten!! :)

Das erste Problem lässt sich ja auch noch auf einem anderen, ziemlich einfachem Weg lösen: Vor dem nächsten Update alle Mails im Posteingang einfach in einen anderen Ordner kopieren. So kann dann, wenn Spami doch noch mal sämtliche Spammails aus der Steinzeit bis jetzt ausgräbt, einfach "Strg+a" und "entf" gedrückt werden. ;)

Das andere Problem setzt sich weiter fort:

Vor dem Update:
mails von "Freunden" -> direkt in Outlook zu sehen
unsicherer non-spam -> landet im Trainingsbereich (mit non-spam Markierung)
unsicherer spam -> landet im Trainingsbereich (mit spam Markierung)
sicherer Spam / mails von geblockten Adressen -> landeten direkt im Papierkorb

*"Freunde" = Adressat ist auf der Liste der Freunde

Nach dem Update:
mails von "Freunden" -> direkt in Outlook
unsicherer non-spam -> landet im Papierkorb
unsicherer spam -> landet im Papierkorb
sicherer Spam / mails von geblockten Adressen -> landeten direkt im Papierkorb
Mails, bei denen ich mir nicht sicher bin, wie ich sie eingestuft habe (entweder Freunde oder ohne Einstufung), finde ich jetzt im Papierkorb wieder - vorher war es entweder direkt in Outlook oder spätestens im Trainingsbereich

Mhm, hat das Update vielleicht meine Sicherheitseinstufung hoch gesetzt?? :?:
Muss ich mal nachschauen...
Dudi
 

Nächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

 industrious-southeast