Remote Desktop

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Re: Remote Desktop

Beitragvon wolle » 21. Jul 2010, 20:30

MadTax hat geschrieben:Ich habe für die Abfrage zwischen Olfolders/Outlook 2003 und Spami den Port auf 112 (wegen anderer Störungen) umgestellt. Ich vermute, deswegen funktionierts.


Da bei mir lokal noch ein Axigen Mailserver läuft und Pegasus Mail als Mailfetcher habe ich so ziemlich alle Ports vom Spammi umkonfiguriert.

POP3: 111
IMAP: 144
POP3 SSL: 996
IMAP SSL: 994

Pegasus holt die Mails durch den Spammi ausschliesslich auf Port 996 ab und forwarded diese dann auf den lokalen SMTP des Axigen Mailservers, welcher wiederum auf dem Standartport lauscht.

So sieht meine Konfig schon immer aus.

Grüssle Wolle
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon FriebelHolger » 22. Jul 2010, 08:31

Hi Wolle,

in der Anlage eine kurze Skizze meiner Konfiguration. Wenn ich Deine richtig verstanden habe, sieht sie so aus, wie in der zweiten Skizze. Das Problem ist, dass derselbe Port am selben Programm zweimal verwendet wird (Entweder Ziffer 1. laut Skizze oder Ziffer 2.). Das ist ansich unschädlich, weil es einmal intern und einmal extern ist und damit zwei verschiedene Ports. Ich habe die Vermutung, dass bei RDP aber wegen der Namensgleicheit beim Umschalten Kollisionen ausgelöst werden. Dafür spricht auch, dass bei einem Neutstart über RDP keine Probleme auftreten. Die Ports werden dann wieder trotz gleichen Namens unterschieden. Nur der Umschaltvorgang läuft nicht in der gewünschten Weise. Ich habe deswegen bei meinem Aufbau darauf geachtet, keinen Portnamen zweimal zu verwenden. Ich hatte vor Jahren schon solche Probleme mit anderen Programmen und versuche es jetzt gar nicht mehr mit gleichen Portnamen. Deshalb kann ich nicht garantieren, dass es daran liegt. Ich halte es aber einen Versuch wert. Falls es nicht klappt, bitte ich Dich, alle verwendeten Ports in einer Skizze gleich der meinen einzutragen und hier zu posten. Dabei solltest Du meine Fehler nicht übernehmen, sondern verbessern ;).

Noch ein Tipp: Die Ports können nicht im Rahmen der Standard - Installation bestimmt werden. Jedenfalls ich kann das nicht. Ich muss immer händisch nachbessern. Dies gilt auch nach Updates. Die Installation führt immer zum "klassischen Aufbau" gemäß Skizze 3. Daran muss ich beim Updaten denken.

FriebelHolger
PS: Wie geht das mit den Anhängen? Wo kann ich das erfahren? Das klappt nicht so wie ich es will.

Spami01_Seite_3.png
"Klassischer" Aufbau
Spami01_Seite_3.png (23.49 KiB) 4837-mal betrachtet


Spami01_Seite_2.png
Wolles Aufbau
Spami01_Seite_2.png (46.98 KiB) 4837-mal betrachtet


Spami01_Seite_1.png
Mein Aufbau
Spami01_Seite_1.png (28.17 KiB) 4837-mal betrachtet
FriebelHolger
Power-User
Power-User
 
Beiträge: 9
Registriert: 12. Jan 2009, 10:18

Re: Remote Desktop

Beitragvon Andreas_Z » 23. Jul 2010, 06:10

Hallo FriebelHolger!

Hmmm... keine Grafiken dran. Kannst Du das noch nachrüsten?

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Remote Desktop

Beitragvon FriebelHolger » 23. Jul 2010, 07:23

Andreas_Z hat geschrieben:Hmmm... keine Grafiken dran. Kannst Du das noch nachrüsten?


Gerne! Aber wie? Ich habe bei der Kontrolle meines Beitrags fetgestellt, dass es mit dem Hochladen nicht geklappt hat. Deshalb habe ich auch das PS ergänzt. Ich versuche es erneut. Allerdings mit geringen Aussichten auf Erfolg, da ich nicht schlauer geworden bin. Liegt es am Format?

FriebelHolger

Spami01_Seite_2.png
Aufbau
Spami01_Seite_2.png (30.09 KiB) 4837-mal betrachtet
FriebelHolger
Power-User
Power-User
 
Beiträge: 9
Registriert: 12. Jan 2009, 10:18

Re: Remote Desktop

Beitragvon Chactory » 23. Jul 2010, 13:10

Hallo FriebelHolger!

Bitte komprimiere Deine Graphiken vor dem Upload noch, dann wird der Server weniger belastet und der User kann die Graphiken schneller sehen (z.B. Abspeichern als gif-Datei). Danach müßtest Du mit Dateianhang hochladen und anschließend im Beitrag anzeigen Erfolg haben.
Vielleicht wirkt hier aber auch noch Michels Sicherung, daß man erst ab einer bestimmten Anzahl Beiträgen die Rechte zum Anzeigen von Graphiken erhält - Schutz vor Forenspammern.
Vielleicht kannst Du dann ausnahmsweise mal über einen Bilderhoster, etwa bild°me, Deine Graphiken dennoch hier posten?

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Remote Desktop

Beitragvon michel » 25. Jul 2010, 10:40

Hallo FriebelHolger!

Vielen Dank für die tollen Skizzen! Ich habe das Format angepasst und die Bilder ein bisschen kleiner gemacht. Jetzt geht es!

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Remote Desktop

Beitragvon michel » 25. Jul 2010, 10:49

Hallo wolle!

Da ich selbst kein Windows Server 2008 besitze, kann ich die Funktion leider nicht testen. Ich würde mich aber freuen, wenn du beim nächsten Beta-Test von Spamihilator dabei wärst. Dann könnten wir zusammen auf die Fehlersuche gehen. Ich nehme an, dass ich die entsprechende Stelle im Code bereits gefunden habe, aber ich kann es wie gesagt nicht testen. Im Beta-Test kann ich dir relativ unkompliziert eine neue Programmversion zur Verfügung stellen. Leider kann ich im Moment noch nicht sagen, wann es wieder einen Test geben wird, da ich viel um die Ohren habe. Ich bemühe mich aber, wieder einen in den nächsten 1-2 Monaten zu machen.

Was meinst du dazu?

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Remote Desktop

Beitragvon Andreas_Z » 26. Jul 2010, 07:09

Hallo michel!

das ist ne gute Idee. Auf diese Weise werden wir die Angelegenheit sicher besser geklärt bekommen. Ich wei jetzt leider nicht aus dem Hut, ob es bei MS eine Möglichkeit gibt, den Win2008 herunterzuladen. Ohne Key läuft der nämlich 180 Tage. Dieser Zeitraum ist zwar nicht zur Evaluierung gedacht......

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Remote Desktop

Beitragvon wolle » 27. Jul 2010, 21:34

michel hat geschrieben:Ich würde mich aber freuen, wenn du beim nächsten Beta-Test von Spamihilator dabei wärst. Dann könnten wir zusammen auf die Fehlersuche gehen.
Was meinst du dazu?


Hi Michel,

sorry für die späte Antwort - immer dieser Freizeitstress ;) Klar kann ich dir da beim Beta Test helfen. Ich hoffe mal, dass die Betas so stabil sind, dass keine Mails verloren gehen.

Schreib mich einfach an, wenn es soweit ist.

Viele Grüße,
Wolle
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon wolle » 27. Jul 2010, 21:37

Andreas_Z hat geschrieben:Hallo michel!

das ist ne gute Idee. Auf diese Weise werden wir die Angelegenheit sicher besser geklärt bekommen. Ich wei jetzt leider nicht aus dem Hut, ob es bei MS eine Möglichkeit gibt, den Win2008 herunterzuladen. Ohne Key läuft der nämlich 180 Tage. Dieser Zeitraum ist zwar nicht zur Evaluierung gedacht......

Gruß
Andreas_Z


Hier http://technet.microsoft.com/de-de/evalcenter/cc137123.aspx sollte es diese geben. Ich glaube aber nicht unbedingt, dass es an der Serverversion liegt. Aber you never know.

Viele Grüße,
Wolle
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon michel » 1. Aug 2010, 12:50

wolle hat geschrieben:Ich hoffe mal, dass die Betas so stabil sind, dass keine Mails verloren gehen.

Klar. Kein Problem. In der nächsten Version wird es hauptsächlich um Fehlerbeseitigung und Verbesserungen der Benutzeroberfläche gehen.

wolle hat geschrieben:Schreib mich einfach an, wenn es soweit ist.

OK. Ich versuche, daran zu denken :-)

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Remote Desktop

Beitragvon anbuva » 1. Aug 2010, 13:58

michel hat geschrieben:Klar. Kein Problem. In der nächsten Version wird es hauptsächlich um Fehlerbeseitigung und Verbesserungen der Benutzeroberfläche gehen.


da Spami im Grunde ja super läuft, halt ich das auch für sehr wichtig; gerade auch um endlich den für mich schon lange gefühlten Stand von Version 1 zu erreichen. :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Remote Desktop

Beitragvon FriebelHolger » 5. Aug 2010, 17:39

Ich habe heute nachmittag ein wenig Zeit mit dem Problem diees Threads verbracht und folgendes festgestellt:

1) Es ist kein ausschließliches Problem des Server 2008
Ich habe meinen Versuch mit XP-Pro SP3 Rechner aufgebaut. Wenn ich mich auf eine aktive Konsolensitzung verbinde, dann steigt Spami aus. Wenn ich mich auf eine getrennte Sitzung oder eine anderweitig aktive Remotesitzung verbinde, geht Spami ohne Probleme weiter.

Das Problem ist das Umschalten von der Konsolensitzung auf eine Remotesitzung. Dies gilt für XP. Bei Server 2008 möchte doch Wolle Bescheid geben, ob er sich mit einer Konsolensitzung, einer getrennten Sitzung oder einer anderweitigen aktiven Sitzung verbindet. Ich bitte ihn zu beachten, dass XP im Gegensatz zu Server nur die Verbindung auf die Konsolensitzung kennt. Die Remotesitzung bei XP ist daher auch eine Konsolensitzung. Beim Server gibt es noch die Verbindung auf eine "normale" Sitzung (ohne Konsole- vorneweg).

2) Die Fehlermeldung, die mein Mailserver in Folge der gescheiterten Verbindung abgibt, lautet:

Error 274d(WSAECONNREFUSED) in connect to 127.0.0.1:112

Vielleicht hilft das jemanden weiter.

3) Meine Lösung (Verschiedene Ports) bringt gar nichts (seufz). Wahrscheinlich benutze ich den Mailserver so selten in der Konsolensitzung, dass es mir bisher nicht aufgefallen ist. Gelegentliche Abstürze fielen bisher unter die Rubrik: It is a feature not a bug! Für gewöhnlich starte ich den Server über WOL und verbinde mich gleich auf die Konsole.

4) Der Spamihilator verursacht die Störung. Beende und starte ich Outlook erneut, kommt immernoch keine Verbindung zustande. Nur wenn der Spamihilator beendet und neu gestartet wird, wird die Verbindung erfolgreich aufgebaut.

Ich habe Vorstehendes mehrmals auf zwei nicht identischen (bis auf das Betriebssystem) Rechnern getestet und sowohl mit Verbindung zu meinem Mailserver als auch mit direkter Verbindung zum Provider. Fremde Programme kann ich daher als Ursache ausschließen. Bei den Ports habe ich alle Varianten durchexerziert, es hatte auf das Fehlerbild keine Auswirkung.

Die Fehlerbeschreibung lautet jedesmal gleich: Wird sich auf eine aktive Konsolensitzung eines Windows XP-Rechner verbunden, so kann das (laufende) Mailprogramm keine Verbindung mehr mit dem (laufenden) Spamihilator herstellen. Bei Aufbau einer Verbindung zu anderen Sitzungen - erkennbar daran, dass das XP des Remoterechners den Willkommensbildschirm zeigt - läuft der Spamihilator ohne Störung weiter.

Vielleichts hilft der Bericht bei der Ursachenforschung und -behebung.

FriebelHolger
FriebelHolger
Power-User
Power-User
 
Beiträge: 9
Registriert: 12. Jan 2009, 10:18

Re: Remote Desktop

Beitragvon wolle » 5. Aug 2010, 19:54

Das Verhalten bei mir entspricht dem von FriebelHolger. Und ja, es kann an der Trennung der Sitzung liegen. Mein Server meldet sich nach dem Booten automatisch mit einem User an. Und wenn ich mich via RDP verbinde übernehme ich genau diese Sitzung. Bei mir gibt es nie den Zustand abgemeldeter User, das würde quasi auch gar nicht gehen, weil mein Pegasus nicht als Dienst laufen kann.
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon FriebelHolger » 5. Aug 2010, 20:58

Hi Wolle, ein möglicher Workaraound: Verbinde dich nicht direkt auf die Sitzung, sondern auf die Sitzung eines anderen Administrators. Dort "Start / Ausführen / Shadow 0" tippen / eingeben und Du bist in der gewünschten Sitzung (aber ohne die Konsolensitzung zu unterbrechen, quasi Bildschirmkopie). Wenn jetzt der Spami noch funktioniert, dann liegt es am Wechselspiel RDP-Umsetzung - Spami. Die Schattensitzung wird mit Strg + * (all drei gleichzeitig, die beiden letzten auf dem Ziffernblock) beendet. Nicht schön, aber besser als nichts. Details bei Microsoft.de

FriebelHolger
FriebelHolger
Power-User
Power-User
 
Beiträge: 9
Registriert: 12. Jan 2009, 10:18

VorherigeNächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron

 industrious-southeast