Remote Desktop

Haben Sie einen Fehler in Spamihilator entdeckt?

Moderator: Forum-Team

Remote Desktop

Beitragvon STEPHANKOENIG » 7. Jan 2010, 22:32

Hi,

wenn ich per Remote Desktop auf meinen XP Rechner zugreife, dann stoppt Spami. Wenn ich ihn beende und neu starte, dann läuft alles wieder einwandfrei.

Hat jemand damit Erfahrungen gemacht ?

Danke

Stephan
STEPHANKOENIG
Spam-Terminator
Spam-Terminator
 
Beiträge: 63
Registriert: 16. Aug 2006, 12:03

Re: Remote Desktop

Beitragvon Chactory » 7. Jan 2010, 22:46

Hallo STEPHANKOENIG!

Bitte lass mal die Forum-Suche darauf los, ich bilde mir ein, mich an eine ähnliche Frage zu erinnern ... Aber ich weiß nicht mehr, ob sie gelöst werden konnte ...

Gruß, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Remote Desktop

Beitragvon STEPHANKOENIG » 8. Jan 2010, 01:57

Danke.

Das ist wohl damals im Sande verlaufen.

Der Vorschlag

mstsc /Console
oder
mstsc /admin

auszuprobieren wurde niemals beantwortet. Aber ich habs jetzt getestet und es läuft nicht.

Stephan
STEPHANKOENIG
Spam-Terminator
Spam-Terminator
 
Beiträge: 63
Registriert: 16. Aug 2006, 12:03

Re: Remote Desktop

Beitragvon michel » 8. Jan 2010, 06:45

Hallo,

das Problem kann ich wahrscheinlich beheben. Ich schreibe es auf die TODO-Liste. Leider haben sich in der letzten Version ein paar Fehler eingeschlichen, die ich zunächst beheben muss, aber ich versuche mein bestes.

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Remote Desktop

Beitragvon STEPHANKOENIG » 8. Jan 2010, 15:54

michel hat geschrieben:das Problem kann ich wahrscheinlich beheben.


Danke Michael, ich freue mich über Deinen Einsatz für uns.

michel hat geschrieben:Leider haben sich in der letzten Version ein paar Fehler eingeschlichen, die ich zunächst beheben muss


Ich hab doch mal irgendwo was davon gehört .... (ich lebe in einer anderen Zeitzone). :)
STEPHANKOENIG
Spam-Terminator
Spam-Terminator
 
Beiträge: 63
Registriert: 16. Aug 2006, 12:03

Re: Remote Desktop

Beitragvon STEPHANKOENIG » 13. Feb 2010, 14:27

Michael,

danke für die neuste Version. ich habe extra ein paar Tage gewartet, aber nun getestet. Auch in meiner Zeitzone läuft alles einwandfrei.

Als Workaround solange die Remote-Desktop Verbindung immer noch den Spami stoppt, überlege ich einen Batch beim Starten des Desktops auszuführen (das ist dort so vorgesehen).

Darin könnte ich den Spami beenden und neu starten.

Was was ist die sicherste Methode, den Spami aus dem Batch zu stoppen ?

Ich kann das natürlich einfach mit Taskkill machen, aber wohl fühle ich mich dabei nicht wirklich.

Danke

Stephan
STEPHANKOENIG
Spam-Terminator
Spam-Terminator
 
Beiträge: 63
Registriert: 16. Aug 2006, 12:03

Re: Remote Desktop

Beitragvon michel » 15. Feb 2010, 21:16

Hallo,

wenn du es schaffst, per Batch die Windows-Nachricht WM_CLOSE an das Fenster mit dem Titel "Spamihilator" zu schicken, dann ist das die sicherste Methode. Mit AutoHotkey müsste das gehen.

Gruß
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Remote Desktop

Beitragvon Andreas_Z » 16. Feb 2010, 08:45

Hallo STEPHANKOENIG!

MS bietet seit einiger Zeit die Powershell an. Die ist sehr mächtig. Die solltest Du Dir mal ansehen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Remote Desktop

Beitragvon anbuva » 25. Feb 2010, 19:06

Hallo Andreas_Z!

hast Du schon damit ein paar Erfahrungen machen können?

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Remote Desktop

Beitragvon Andreas_Z » 26. Feb 2010, 07:20

Hallo anbuva!

Nee. Ich habe fast keine Anwendung für so mächtige Funktionen. Aber in der letzten c'ts wurde darüber geschrieben. Das war sehr interessant. Das ganze kommt langsam der Linux-Shell nahe.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Remote Desktop

Beitragvon anbuva » 26. Feb 2010, 10:10

Hallo Andreas_Z!

Super :D . Ich hänge mit dem Lesen immer ein paar Ausgaben nach. Dann werde ich ja auch noch dazu kommen. In den letzten 1,5 Wochen konnte ich ja zwangsweise ja so einiges bei meinen Büchern, Magazinen etc. nachholen... :wink:

Gruß
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Remote Desktop

Beitragvon wolle » 16. Apr 2010, 10:08

STEPHANKOENIG hat geschrieben:Hi,

wenn ich per Remote Desktop auf meinen XP Rechner zugreife, dann stoppt Spami. Wenn ich ihn beende und neu starte, dann läuft alles wieder einwandfrei.

Ahhh gut zu lesen, dass es "nur" beendet wird. Ich dachte nämlich immer, dass etwas mit dem Lauschen auf dem Localhost-Port nicht stimmt, denn das Tryicon verschwindet ja nicht. Ich habe gerade eben einen erfolgreichen Test gemacht während einer RDP-Sitzung den Spami zu beenden und dann neu zu starten. Der erste Versuch war erfolgreich. Ich werde es weiterhin beobachten....

Wie wäre es denn den Zustand des Spamis über einen Localhostzugriff abzufragen und zwar von einem weiteren, unabhängigem Task. Sollte der Spammi nicht erreichbar sein, werden übrige Taskreste gekillt und dieser neu gestartet. Das wär doch auch ein Ansatz...Oder ?!

Viele Grüße,
Wolle
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon Andreas_Z » 19. Apr 2010, 07:24

Hallo wolle!

wie rufst Du denn die RDP-Session auf? Einfach nur
Code: Alles auswählen
%systemroot%\system32\mstsc.exe
oder
Code: Alles auswählen
%systemroot%\system32\mstsc.exe /admin
? Im letzteren Fall wirst Du direkt mit dem ersten Desktop verbunden. Im anderen Fall wird ein neuer aufgemacht. Beim neu aufmachen müßten dann auch alle Autostartprozesse ein weiteres mal gestartet werden. Es kann sein, dass hier die Fähigkeiten des RDP-Tools zur Trennung der Sessions nicht weit genug reichen und deshalb Spami merkt, dass es bereits gestartet wurde.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Re: Remote Desktop

Beitragvon wolle » 19. Apr 2010, 21:17

Hallo Andreas_Z,

ich benutze die erstere Variante (%systemroot%\system32\mstsc.exe) und bekomme beim Server 2008 auch immer brav den selben Desktop. Es läuft also kein Loginscript zum x-ten mal ab. Die Session wird immer schön getrennt (also nicht abgemeldet) und das nächste Mal sieht wieder alles wie zuvor aus.

Viele Grüße,
Wolle
wolle
Power-User
Power-User
 
Beiträge: 14
Registriert: 18. Sep 2008, 22:02

Re: Remote Desktop

Beitragvon Andreas_Z » 20. Apr 2010, 06:41

Hallo wolle!

Hast Du es denn schon mal auf die andere Art und Weise versucht? Trotzdem verwundert mich das von Dir geschilderte Verhalten. Wenn die Session nur getrennt wird, sollte doch alles unverändert bleiben. Hmmm.... da bin ich mit meinem Latein auch am Ende. Vielleicht ist das ja eine RDP-Problem und keines von Spami. Vielleicht solltest Du mal einen Thread im MCSEBoard aufmachen.

Gruß
Andreas_Z
Core i7 3,4 GHz, 8 GB RAM, Win7 64bit SP1, GDATA Bussiness 11.0
Exchange-Server 2003, VM mit WinXP Pro SP3.
Spami-Online-Hilfe, Spami-FAQ, Anbuva's FAQ
Benutzeravatar
Andreas_Z
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 4380
Registriert: 6. Nov 2003, 08:10
Wohnort: Schwielowsee, Germany

Nächste

Zurück zu Bugs

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron

 industrious-southeast