Spami and IMAP Special Folders

For all users, who don't speak German!

Moderator: Forum-Team

Spami and IMAP Special Folders

Beitragvon The Merg » 8. Apr 2014, 18:10

I was able to get Spamihilator set up and working with my IMAP email client (eM Client). It works for me, but I have one major issue. In eM Client, you can specify what the IMAP special folders are or have eM Client detect them for you (Sent, Drafts, Junk, Trash). Whenever I try to use Spamihilator, the mail client cannot seem to detect these folders. Thus, whenever I try to delete something or sent it to the Junk folder, I get an error that the folder cannot be created on the server.

Any thoughts on how to get this to work? I really, really, really need an anti-spam filter and Spamihilator seems like my best option if I can get it to work.

Thanks,
Merg
Today's problems don't worry me,
I haven't solved yesterday's yet.
Benutzeravatar
The Merg
Power-User
Power-User
 
Beiträge: 5
Registriert: 8. Apr 2014, 02:10

Re: Spami and IMAP Special Folders

Beitragvon Chactory » 8. Apr 2014, 23:03

Hello Merg!

Thank you for your question and for your friendly note. :)

Will it work, wenn you activate (check) the setting marked with a yellow arrow in the following image?
zwi-.png
zwi-.png (45.86 KiB) 12296-mal betrachtet

Kind regards,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami and IMAP Special Folders

Beitragvon The Merg » 9. Apr 2014, 00:43

Hi Chactory!

Thanks for the reply. Unfortunately, it still does not work. While, Spamihilator is doing it's job, eM Client is not seeing the special IMAP folders when I connect through Spamihilator. I've included some screen shots of my setup.

This is the error I get when deleting an email:
Error When Deleting Email.jpg
Error When Deleting Email
Error When Deleting Email.jpg (58.93 KiB) 12292-mal betrachtet


This is the folder listing for an account with the correct special folders:
Correct Folder List.jpg
This is the correct folder listing with Special Folders
Correct Folder List.jpg (7.47 KiB) 12292-mal betrachtet


This is the folder listing for my account after Spamihilator is activated:
The Merg Folder List.jpg
The Merg Folder List
The Merg Folder List.jpg (13.4 KiB) 12292-mal betrachtet

You can see that there is an extra Trash folder and the Junk folder is not renamed to Junk E-mail as it is not seeing that as a special folder.

More to follow...

Regards,
The Merg
Zuletzt geändert von The Merg am 9. Apr 2014, 00:57, insgesamt 1-mal geändert.
Today's problems don't worry me,
I haven't solved yesterday's yet.
Benutzeravatar
The Merg
Power-User
Power-User
 
Beiträge: 5
Registriert: 8. Apr 2014, 02:10

Re: Spami and IMAP Special Folders

Beitragvon The Merg » 9. Apr 2014, 00:44

Hi Chactory!

Here are my settings in Spamihilator:

Spamihilator Settings 1.jpg
Spamihilator Settings 1.jpg (166.78 KiB) 12292-mal betrachtet


Spamihilator Settings 2.jpg
Spamihilator Settings 2.jpg (143.12 KiB) 12292-mal betrachtet


Here is my setup in eM Client:
eM Client Setup.jpg
eM Client Setup.jpg (47.2 KiB) 12292-mal betrachtet


Using any other setting in the Port/Security Policy section of the eM Client setup makes it so that I can't connect at all. I've tried multiple combinations of Port 143/993 and SSL settings.

Any thoughts?

Thanks,
The Merg
Today's problems don't worry me,
I haven't solved yesterday's yet.
Benutzeravatar
The Merg
Power-User
Power-User
 
Beiträge: 5
Registriert: 8. Apr 2014, 02:10

Re: Spami and IMAP Special Folders

Beitragvon The Merg » 9. Apr 2014, 00:59

I also noticed that when emails do come through to my inbox, I seem to only be getting the header. When I click on the email, it says that the body cannot be downloaded as I am not connected to the server and that it will download the next time I connect.

- Merg
Today's problems don't worry me,
I haven't solved yesterday's yet.
Benutzeravatar
The Merg
Power-User
Power-User
 
Beiträge: 5
Registriert: 8. Apr 2014, 02:10

Re: Spami and IMAP Special Folders

Beitragvon Chactory » 13. Apr 2014, 16:22

Hello Merg!

Chactory hat geschrieben:Will it work, wenn you activate (check) the setting marked with a yellow arrow in the following image?
The Merg hat geschrieben:Unfortunately, it still does not work. While Spamihilator is doing it's job, eM Client is not seeing the special IMAP folders when I connect through Spamihilator.
The Merg hat geschrieben:Here are my settings in Spamihilator: Check all folders for spam (not only inbox)
Here is my setup in eM Client: IMAP: port 993, don’t use secure connection
Credentials: User name: mailserver&mailadress&port993
Automatically detect special folder names

Sorry, but I have no experience with eM Client until now. But I have a thought about the possible problematic spot in your settings:

You have erroneously set the IMAP port in your mail-client as 993, which is the secure-settings port. But you should set the mail-reception in your mail-client on normal, not secure. So this means, the port should be made out to 143. Within the user-name field, you don’t need to repeat the port number.

Noteably, in the eM Client you can also choose if you want to detect special folder names automatically. Maybe this setting should always be concordant in eM Client and Spamihilator, but I don’t really know.

Kind regards,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami and IMAP Special Folders

Beitragvon The Merg » 20. Apr 2014, 17:01

Chactory hat geschrieben:Hello Merg!

Chactory hat geschrieben:Will it work, wenn you activate (check) the setting marked with a yellow arrow in the following image?
The Merg hat geschrieben:Unfortunately, it still does not work. While Spamihilator is doing it's job, eM Client is not seeing the special IMAP folders when I connect through Spamihilator.
The Merg hat geschrieben:Here are my settings in Spamihilator: Check all folders for spam (not only inbox)
Here is my setup in eM Client: IMAP: port 993, don’t use secure connection
Credentials: User name: mailserver&mailadress&port993
Automatically detect special folder names

Sorry, but I have no experience with eM Client until now. But I have a thought about the possible problematic spot in your settings:

You have erroneously set the IMAP port in your mail-client as 993, which is the secure-settings port. But you should set the mail-reception in your mail-client on normal, not secure. So this means, the port should be made out to 143. Within the user-name field, you don’t need to repeat the port number.

Noteably, in the eM Client you can also choose if you want to detect special folder names automatically. Maybe this setting should always be concordant in eM Client and Spamihilator, but I don’t really know.

Kind regards,
Chactory


Okay. I tried your suggestion of fixing the IMAP port and still had no luck. You mention about the option of detecting special folder names in Spamihilator, but I don't see that option anywhere. Where do I find that option? In eM Client, I tried it with that option turned on and turned off to no avail. Were you actually able to get Spamihilator to work with eM Client and IMAP?

Thanks,
Merg
Today's problems don't worry me,
I haven't solved yesterday's yet.
Benutzeravatar
The Merg
Power-User
Power-User
 
Beiträge: 5
Registriert: 8. Apr 2014, 02:10

Re: Spami and IMAP Special Folders

Beitragvon Chactory » 27. Apr 2014, 10:44

The Merg hat geschrieben:You mention about the option of detecting special folder names in Spamihilator, but I don't see that option anywhere. Where do I find that option?

Please note both yello marks in the screen shot:
qwen.png
qwen.png (44.86 KiB) 12194-mal betrachtet
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami and IMAP Special Folders

Beitragvon Skamandros » 11. Okt 2015, 10:35

I have the same problem and have unfortunately not been able to solve it yet.
Skamandros
 

Re: Spami and IMAP Special Folders

Beitragvon Chactory » 11. Okt 2015, 15:42

Hi, and thank you for your question.
Is it with IMAP and em client, too?
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Spami and IMAP Special Folders

Beitragvon Skamandros » 11. Okt 2015, 22:28

Chactory hat geschrieben:Hi, and thank you for your question.
Is it with IMAP and em client, too?


Yes, it is with IMAP and eM Client too. But I think I have been able to narrow down or probably solve the problem: It seems that the mail server doesn't support other folders than the Inbox on the root level. Rather they have to be nested below the inbox directory. eM Client is however unable to detect this automatically. It seems to work when I disable automatic detection of special folder names in eM Client and set all settings manually like this:

Sent: Inbox.Sent
Drafts: Inbox.Drafts
Trash: Inbox.Trash
Junk: Inbox.Spam

So, this actually doesn't seem to have anything to do with Spamihilator.
Skamandros
 

Re: Spami and IMAP Special Folders

Beitragvon Chactory » 12. Okt 2015, 21:04

Skamandros hat geschrieben:It seems that the mail server doesn't support other folders than the Inbox on the root level. Rather they have to be nested below the inbox directory. eM Client is however unable to detect this automatically. It seems to work when I disable automatic detection of special folder names in eM Client and set all settings manually like this
8) 8)
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)


Zurück zu English Forum

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

 industrious-southeast