Dates are not correct in 0.9.9.52

For all users, who don't speak German!

Moderator: Forum-Team

Dates are not correct in 0.9.9.52

Beitragvon onlymemdm » 24. Dez 2009, 16:07

I've just installed the new version on Windows 7, 64Bit. Since I couldn't find a 64Bit version of the Whitestring Filter which I rely upon heavily, I installed the 32Bit version of Spami. It's running really well except for the handling of dates. See the attached screenshot of the Recycle Bin. It's currently Christmas Eve (12/24/2009) in the U.S., not 2/7/2010! This problem is also causing the Statistics Area to be empty. It reflects "0" mails in the past 30 days when in actuality I've received and Spami has processed a few hundred. Any ideas as to how to fix the invalid date issue?
Dateianhänge
spami-dates.jpg
Screen shot of invalid dates in Recycle Bin.
spami-dates.jpg (245.1 KiB) 4536-mal betrachtet
onlymemdm
User
User
 
Beiträge: 2
Registriert: 24. Dez 2009, 15:50

Re: Dates are not correct in 0.9.9.52

Beitragvon Bob Loeffler » 26. Dez 2009, 20:43

Hi onlymemdm and Michel,

I also see the problem in the Training area after installing .52 (32bit) today. All of the dates show up as "2/9/2010" for e-mails that were downloaded today (Dec. 26, 2009).

Regards,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Dates are not correct in 0.9.9.52

Beitragvon anbuva » 26. Dez 2009, 22:17

Hallo !

no problems here...

Regards
anbuva
Benutzeravatar
anbuva
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 8403
Registriert: 1. Sep 2004, 12:58
Wohnort: Zuhause

Re: Dates are not correct in 0.9.9.52

Beitragvon michel » 27. Dez 2009, 14:45

Hi!

Is this a problem of people living in the USA? Could you please check that and set your time zone to Berlin temporarily?

Bye,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Dates are not correct in 0.9.9.52

Beitragvon Bob Loeffler » 28. Dez 2009, 05:11

Hi Michel,

I just changed my timezone to Berlin time and restarted Spami. I will let you know if that changes the date/time in the Training area.

Thanks,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Dates are not correct in 0.9.9.52

Beitragvon Bob Loeffler » 28. Dez 2009, 05:50

Hi Michel,

Yes, changing the timezone to Berlin time fixes the problem. The dates are correct in the Training area for new e-mails. But I can't leave the timezone at Berlin time, so I have changed it back to Mountain timezone (-7). Now they will be incorrect dates again. :-(

Thanks,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Dates are not correct in 0.9.9.52

Beitragvon michel » 28. Dez 2009, 09:39

Hi!

Thanks for the test. This is very weird. You did not notice that problem in earlier versions, did you?

Thanks,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Dates are not correct in 0.9.9.52

Beitragvon Ponder » 29. Dez 2009, 01:35

Hello all

I also have the same date...time problem...reset to Berlin time then dates of mails were OK....but can't keep the PC set at Berlin time......Then went back to eastern time (USA) and new mails are again dated next year.

Previous versions did not have this issue.....Ponder
Benutzeravatar
Ponder
Spam-Terminator
Spam-Terminator
 
Beiträge: 78
Registriert: 2. Apr 2007, 02:51
Wohnort: Gainesville, Georgia

Re: Dates are not correct in 0.9.9.52

Beitragvon michel » 29. Dez 2009, 16:31

Ponder hat geschrieben:Previous versions did not have this issue.....Ponder

OK. Then I will have to check was I changed between these two versions that could lead to this problem.

Thanks for your help. I'll keep you informed.

Regards,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: Dates are not correct in 0.9.9.52

Beitragvon Bob Loeffler » 30. Dez 2009, 06:48

The last version that I had was .44 and it did not have this problem.

Thanks,

Bob
English Spamihilator FAQ - Spamihilator questions and answers in English!
Author of these plugins and filters: Attachment Extensions Filter, Empty Mail Filter, HTML Links Filter, No Comment! Filter, Plain Text Links Filter, Scripts Filter, Unclassified Filter, Export Senders Plugin and Filter Statistics Plugin. See the details here!
Benutzeravatar
Bob Loeffler
 
Forum-Team
Plugin-Programmierer
 
Beiträge: 1132
Registriert: 5. Dez 2003, 20:20
Wohnort: Colorado, USA

Re: Dates are not correct in 0.9.9.52

Beitragvon thirstee » 31. Dez 2009, 01:31

Same issue for me in the USA. No prev version did this.
thirstee
 

Re: Dates are not correct in 0.9.9.52

Beitragvon djwind » 1. Jan 2010, 14:27

Hi michel!

I just updated my Spami ver to 0.9.9.52 and the same problem with wrong dates happened. Did change to Berlin - dates OK, went back to Sao Paulo, Brazil time - back to the problem. Previous versions never had this problem and I have been using Spami for over 2 years. It seems that it adds 45 days to the current date - mail received today - Jan 1, 2010 is showing as Feb 15, 2010. I looked into the details of the message from within the training and from within the recycling area with headers et al, and there is no reference to the date showing in Spami. I would speculate that it is something to do with date to keep in Spami until it gets deleted from server. This is just a wild guess !!! Please advise if you find the bug.

Regards,
djwind
djwind
User
User
 
Beiträge: 2
Registriert: 1. Jan 2010, 14:17

Re: Dates are not correct in 0.9.9.52

Beitragvon michel » 1. Jan 2010, 18:36

Hi!

I will fix the bug and release a new version probably at the end of January. Please stay tuned! And sorry for the inconvience caused.

Sincerely,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck


Zurück zu English Forum

Wer ist online?

Mitglieder in diesem Forum: Majestic-12 [Bot] und 5 Gäste

cron

 industrious-southeast