Lost emails :-(

For all users, who don't speak German!

Moderator: Forum-Team

Lost emails :-(

Beitragvon RedMist » 21. Sep 2009, 11:31

I have set up Spami to work with an IMAP server.

Some important emails came in, but were incorrectly marked as spam. They were manually marked as "Non-Spam" and "Learnt"

I clicked "Send/Receive" in Outlook and the emails went from Spami, however, they never appeared in Outlook. They appear to have been lost forever. I've looked on the server, using a webmail client, and they are not there. :-(

Can anyone explain what might have happened?

Thanks a lot,

Rob
RedMist
User
User
 
Beiträge: 2
Registriert: 7. Sep 2009, 16:09

Re: Lost emails :-(

Beitragvon Chactory » 21. Sep 2009, 14:54

Hello RedMist!

That's very bad, of course! :evil:

Sorry, I'm not producing very good solutions hereto, but one thought I have is, please look into your mail client's junk folder to check the function of the built-in junk filter. Perhaps it may help to read the Vista FAQ of Anbuva, item 25 about IMAP.

Regards, Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: Lost emails :-(

Beitragvon davidm » 26. Nov 2010, 21:18

I'm actually having this exact same problem. I use Thunderbird 3.1.6 on one computer and Outlook 2007 on another computer. Both use IMAP, and I have four email accounts. I installed Spami on my computer running Thunderbird to test the spam filtering before trying it on the computer running Outlook.

To start with, I was getting a lot of false positives from the DCC filter, since I belong to a number of mailing lists. I would mark the false positives as non-spam in the training area, mark the remaining messages in the training area as spam or non-spam, click the Learn button, then check the recycle bin. The false positives that I marked as non-spam were listed in the recycle bin with the yellow Restore arrow next to them (as they should), then they would eventually disappear. However, the false positives that I marked as non-spam that were supposed to be restored never showed up in my mail client and were no longer on the mail server.

The only way I could get around this was to go into Settings-->Recycle Bin and check the "Keep Spam Mails on the server until I delete them from the Recycle Bin" box. However, this kind of defeats the purpose of the spam filter, since this causes all of the spam mail to clog up my Inbox until I remove them from the Recycle Bin.

Could this have something to do with the IMAP protocol specifically? I read that restored emails (originally marked as spam) that had already been deleted from the mail server would be passed through to the local mail client only (meaning that email clients on other computers checking the same mailbox would never receive the restored message). So if the message has been deleted from the server and Spami passes the message through to the email client, then the next time the email client synchronizes the folder with the server, wouldn't it notice that the message has been deleted from the server and respond by deleting it from the client as well?

Thanks in advance,
David
davidm
User
User
 
Beiträge: 1
Registriert: 26. Nov 2010, 20:21

Re: Lost emails :-(

Beitragvon michel » 28. Nov 2010, 11:18

Hi!

Restoring messages on IMAP accounts is different. Therefore the APPEND command is used, so the message will actually be rewritten to the server! You can check that by looking into the server.log file which can be found in your application data directory (see http://wiki.spamihilator.com/doku.php?i ... onfigfiles). Search for the APPEND command or for any error (usually marked by NO oder BAD). You may also send this file to me via email so I can analyze it.

Bye,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck


Zurück zu English Forum

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste

cron

 industrious-southeast