«invalid characters»

For all users, who don't speak German!

Moderator: Forum-Team

«invalid characters»

Beitragvon Olivier Hammam » 2. Apr 2009, 09:44

As a french user I receive some mails with accented chars in the sender's alias; also, I receive, as anybody, spams from countries that don't use the common characters sets (China, Japan, Russia, etc.). And I can't add these adresses to friends or blocked senders because of the «invalid characters» filter. I saw that some users asked for an unicode support, but there is another way: no need to «understand» (recognize) the extended characters to handle these adresses, I think that there is no reason to consider these characters as «invalid».

For example, there is a sender that appears as «NewsLetter Libération» in my mail software and as «NewsLetter Libération» through Spamihilator. As it seems to me, «Ã©» are «valid characters» as long as the sender's name «NewsLetter Libération» appears each time in the same form, and this is.

I suggest to allow « strange » characters in the sender's alias.
Zuletzt geändert von Olivier Hammam am 6. Apr 2009, 19:56, insgesamt 1-mal geändert.
Olivier Hammam
User
User
 
Beiträge: 2
Registriert: 22. Sep 2008, 04:55

Re: «invalid characters»

Beitragvon michel » 6. Apr 2009, 19:04

Hello Olivier,

thank you for your contribution. The characters are considered invalid because the senders are saved in a .ini file where they might cause problems. In the future they will be saved in a SQLite database. This should solve this issue. I added this feature to my TODO list.

Sincerely,
Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: «invalid characters»

Beitragvon Olivier Hammam » 6. Apr 2009, 19:54

Hi michel!

Thanks a lot for your answer.

Regards,
Olivier Hammam
Olivier Hammam
User
User
 
Beiträge: 2
Registriert: 22. Sep 2008, 04:55

Re: «invalid characters»

Beitragvon RetiredFed » 31. Mai 2012, 22:57

Hallo michel!
I assume that the SQL database was added to v1.0.
My problem adding friends who have accented characters in their names remains since I had to uninstall v1.0 when it seemed to mis-function and I had to re-install v0.9.9.44 that I had running previously.
Would any of the Beta's contain the sql version?

I am running Spami on an XP SP3 on a Thinkpad T60.

Gruß
RetiredFed
RetiredFed
Power-User
Power-User
 
Beiträge: 8
Registriert: 16. Dez 2005, 21:26

Re: «invalid characters»

Beitragvon Chactory » 4. Jun 2012, 21:25

Hello RetiredFed!

I'm going to alert Michel about your question, for I can't answer it for him.

Regards,
Chactory
HilfeHelp «en»TippsAnbuva's FAQBob's FAQ «en»SpamwortlisteRegelfilterScreenshotsSSL/TLSSpami 1.6.0
Vostro 3450, Intel Core i5 2410M 2,3 GHz, 4 GB DDR3 SDRAM 1333 MHz, Windows 7 Pro 64 Bit SP1

Bild
Benutzeravatar
Chactory
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
 
Beiträge: 9593
Registriert: 9. Jan 2004, 23:19
Wohnort: Kiel (D)

Re: «invalid characters»

Beitragvon Quellcore » 4. Jun 2012, 23:29

Hello RetiredFed!

0.9.9.54: Michel Krämer (07/08/10)
- improved storage of senders: they will be saved in a Sqlite
database now

http://www.filefactory.com/file/5obu7uxn006r/n/Spamihilator-win32-0_9_9_54_exe

Regards,
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: «invalid characters»

Beitragvon Quellcore » 5. Jun 2012, 02:29

Hello RetiredFed!
RetiredFed hat geschrieben:...I had to uninstall v1.0 when it seemed to mis-function...

May i ask for more details about "mis-function" :?:
Sounds mysterious, but could most likely be solved easily.

Regards,
Quellcore
CPU:Intel Core i7-2700K Processor (@ 45*100 = 4500 MHz)
Board:ASRock P67 Extreme4 Gen3
Ram: 16GB G.SKILL Ripjaws X Series (4 x 4GB) DDR3 2133 (Timings 10-10-10-28 2T @ 1866 MHz)
SSD: Samsung 128GB 2.5-inch SSD 830 Series (Desktop)
HDD-1: WD Caviar® SE16 640 GB, SATA2, 16 MB Cache, 7200 RPM
HDD-2: SAMSUNG EcoGreen F4 ST2000DL004 2TB 32MB Cache
Graphic: ATI Radeon HD 5850 ASUS EAH5850/G/2DIS/1GD5

Win 7 Ultimate 64-Bit / ESET NOD32 Antivirus 8.0 / Firefox 34 / Thunderbird 31
Spamihilator 1.6.0
Benutzeravatar
Quellcore
Assistent
Assistent
 
Beta-Tester
 
Beiträge: 1706
Registriert: 8. Mai 2004, 13:03
Wohnort: Long Island / USA

Re: «invalid characters»

Beitragvon michel » 9. Jun 2012, 16:03

Hi!

Yes, that would also be interesting for me. RetiredFed, can you give us more information please? Thanks.

Michel
Chuck Norris doesn't kill Spam. He uses Spamihilator! ;-)
Benutzeravatar
michel
Administrator
Administrator
 
Administration
Beta-Tester
Forum-Team
Plugin-Programmierer
 
Beiträge: 4335
Registriert: 22. Mär 2003, 01:16
Wohnort: Buseck

Re: «invalid characters»

Beitragvon RetiredFed » 22. Jun 2012, 01:50

Hallo michel!
Eventually, I will try to reinstall the newer version of Spami...later...maybe 1.x.
So, for now, I will not try to duplicate the problem that I encountered. Sorry.

For the moment, I am content to stay with 9.9.44 because it works ok for me.

Am I correct to assume that Spami only needs a Name associated with the emailaddress. It is the emailaddress that gets filtered, not the name associated with it. The DisplayName does not have to exactly duplicate the Name received.

My work-around that seems to resolve the accented character problem is to delete the part of the name that contains such accented characters.

The actual username@ispdomain.com never, contains accented characters. IAW RFC5322. So the Spami INI file in this 9.9.44 version of Spami will contain, e.g. the DisplayFirstname only and the email-username@isp.com with the DisplayLastname deleted if it contained the accented character:"Jose" instead of "Jose García" or "Jose Peña".

So, as long as the email address is compliant with RFC5322, Spami 9.9.44 should be ok?
If RFC6530 ever gets implemented, then I will need an update Spami version. The SQLLite will work with RFC6530?

http://en.wikipedia.org/wiki/Email_addr ... n_Examples


Gruß
RetiredFed
RetiredFed
Power-User
Power-User
 
Beiträge: 8
Registriert: 16. Dez 2005, 21:26

Re: «invalid characters»

Beitragvon RetiredFed » 22. Jun 2012, 02:26

I guess it is your implementation of UTF8 that will allow the international character set?
I was not familiar with UTF8. At first I thought it dealt with MIME issues.
But, how many mailservers in the US and Europe can deal with UTF8?

Your user base probably has a need for UTF8, but I doubt I will have any correspondents with UTF8 addresses in the near future.
RetiredFed
Power-User
Power-User
 
Beiträge: 8
Registriert: 16. Dez 2005, 21:26


Zurück zu English Forum

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron

 industrious-southeast