DNSBL-Plugin

Antwort erstellen

Bestätigungscode
Gib den Code genau so ein, wie du ihn siehst; Groß- und Kleinschreibung wird nicht unterschieden.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:
BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet
Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: DNSBL-Plugin

Re: DNSBL-Plugin

Beitrag von Quellcore » 24. Jun 2011, 00:50

Hallo Hexmaster!

Das nenn' ich mal "kurz und schmerzlos", weiterhin viel Spaß mit dem Spami!

Gruß
Quellcore

P.S. ... und Finger weg von alten Plugins!!! :wink:

Re: DNSBL-Plugin

Beitrag von Hexmaster » 24. Jun 2011, 00:23

Quellcore hat geschrieben:Hallo Hexmaster!
Evtl. haben Deine Freunde neue Mailadressen?


LOL... ich glaube das jetzt nicht... du hast Recht. Mein Freund hat mich mit einer anderen Mailadresse angeschrieben. Das ist mir garnicht aufgefallen. Danke dir... manchmal sieht man den Wald vor lauter Bäume nicht :wink:

Re: DNSBL-Plugin

Beitrag von Quellcore » 23. Jun 2011, 22:49

Hallo Hexmaster!

Nein, kein Gedankenfehler.
Deine Vorstellung vom Arbeitsablauf ist definitv korrekt.
Die Freundesliste ist dominant.
Es muss also etwas anderes sein!?
Evtl. haben Deine Freunde neue Mailadressen?


Gruß
Quellcore

Re: DNSBL-Plugin

Beitrag von Hexmaster » 23. Jun 2011, 19:51

Also, ich bin bisher immer davon ausgegangen, wenn ich eine Addy auf die Freundesliste setze, das Mails, welche von der Addy eintreffen, garnicht erst durch die Filter läuft, sondern unangetastet an das Mail-Programm weiter geleitet wird.

Heute habe ich 2 Mails von einem Freund erhalten (steht in der Freundesliste), deren Mails vom DNSBL Filter als Spam eingestufft wurde. Was läuft da falsch... oder hab ich da jetzt einen Gedankenfehler?

Re: DNSBL-Plugin

Beitrag von Andreas_Z » 25. Mär 2011, 09:27

Hallo anbuva!

Jau. Linux hats Jahre lange vorgemacht. Uns ehrlich gesagt kenne ich keinen User, der sich mit den Sicherheitsvorgaben des Betriebssystems arangiert hätte. Linux-User habe immer so gearbeitet und sich nie beschwert. Im Gegenteil ist Ihnen schnell der Vorteil aufgegangen. Das die User das dann so wollten, war pure Gewohnheit und falsche Informationspolitik. Aber ich sehe Licht am Horizont.

Gruß
Andreas_Z

Re: DNSBL-Plugin

Beitrag von anbuva » 24. Mär 2011, 16:58

Hallo Andreas_Z!

da muss man MS leider recht geben. Aber sicherlich war es auch einfach der Gewöhnungstrott und alles überall machen zu dürfen. Der User wollte es so und sich nicht bevormunden lassen. Letztendlich war der programmtechnische Aufwand auch geringer. Bin mir sicher, dass durch eine vernünftige Userstruktur mit Rechten man vieles hätte verbessern können; auch die Sicherheit.

Gruß
anbuva

Re: DNSBL-Plugin

Beitrag von Andreas_Z » 24. Mär 2011, 08:20

Hallo Hexmaster!

Na, wie ich befürchtet habe. Ist zwar ein Workaround, dürfte aber für die meisten nicht wirklich Praktikabel sein. Schade. Das Schlimme daran ist eigentlich, dass es nicht MS verbogt hat, sondern die Programmierer. MS hat schon zu seligen XP-Zeiten passende Empfehlungen für den Mehrbenutzerbetrieb gegeben.

Gruß
Andreas_Z

Re: DNSBL-Plugin

Beitrag von anbuva » 23. Mär 2011, 17:54

Hallo Hexmaster!

das wäre dann für mich(!) problematisch, da ich immer nur als User mit eingeschränkten Rechten arbeite (was man ja generell tun sollte). Insofern finde ich es zwar schön, dass Du für Dich eine Lösung gefunden hast, kann es aber dann hier leider offiziell nicht weiterempfehlen. Trotzdem danke für Deine Mühe und die Darstellung der Möglichkeit und ich hoffe weiterhin, dass wir dieses PlugIn noch einmal in einer neu aufgelegten Version wieder begrüßen dürfen.

Gruß
anbuva

Re: DNSBL-Plugin

Beitrag von Hexmaster » 23. Mär 2011, 12:44

@Andreas_Z: Ja, ich arbeite mit Admin Rechten.

Zum Userprofil, das hab ich gefunden. Das DNSBL Plugin selber taucht dort nicht auf, dort ist nur das Icon von DNSBL zu finden: DNSBL.ico.

Re: DNSBL-Plugin

Beitrag von Andreas_Z » 23. Mär 2011, 07:31

Hallo anbuva!

Das ist ne gute Frage. Dem Pfad nach zu urteilen, wird es wohl eher keine echte Mehrbenutzerfähigkeit geben. Aber gewissheit kann uns jetzt eigentlich nur Hexmaster geben.

@Hexmaster: Kannst Du mal bitte in Deinem Userprofil nach einem Ordner namens Spamihilator suchen und dort überprüfen, ob das DNSBL-Plugin dort auch auftaucht? Arbeitest Du mit Adminrechten?

Gruß
Andreas_Z

Re: DNSBL-Plugin

Beitrag von anbuva » 22. Mär 2011, 18:10

Hallo Andreas_Z!

Was mich noch vom Verständnis noch interessieren würde (und was ich noch nicht herausgelesen oder übersehen habe); wie sieht es mit eingeschränkten Rechten eines Users aus? Kann ein User mit eingeschränkten Rechten die Datei dann nutzen? Liegen die Daten dann alle im User-Verzeichnis und wird darauf auch tatsächlich zugegriffen; sprich wäre nach einen manuellen Eingriff damit dann tatsächlich eine Mehrbenutzerfähigkeit gegeben? :?

Gruß
anbuva

Re: DNSBL-Plugin

Beitrag von Andreas_Z » 22. Mär 2011, 08:09

Hallo Hexmaster!

Super. Viel Spaß weiterhin und vielen Dank für Deine Rückmeldung. Das hört sich fast wie ein echter Workaround an, um das Plugin noch eine Weile weiter betreiben zu können. Anbuva ist sicher begeistert.

Gruß
Andreas_Z

Re: DNSBL-Plugin

Beitrag von Hexmaster » 21. Mär 2011, 23:13

Danke Andreas_Z, durch dich bzw deine Antwort, hab ich den Fehler gefunden. Und nun funktioniert es, Spami behält die Einträge :D

Also, Procmon.exe gestartet, dann Spami gestartet. Sofort massig Prozesse. Ich hab dann das Log nach der DNSBL.ini durchsuchen lassen. Die dll wollte auf die ini zugreifen und konnte sie nicht finden, da der Pfad nicht existiert. Und das schöne ist, er schreibt mir gleich den Pfad hin, wo er drauf zugreifen wollte. In diesem Fall wurde die ini in diesem Pfad gesucht:

C:\Program Files\Spamihilator\bridge\plugins

Ich habe die ini direkt unter spamihilator\plugins gelegt, da dort auch die dll ist. Dann hab ich sie noch im Userverzeichnis von Spami gelegt. Nunja, bis bridge stimmte der Pfad, ein Unterordner mit Namen "plugin", gabs allerdings nicht. Ich habe den Ordner erstellt und die ini dorthin verschoben, danach Spami neu gestartet. Und siehe da, schon finde ich zusätzlich noch ein DNSBL.log und eine RFCValidator.ini. Das letztere da auch fehlte, war mir bis dato garnicht bewußt.

Lange Rede, kurzer Sinn... danke für deine Hilfe.

Gruß Hex

Re: DNSBL-Plugin

Beitrag von Andreas_Z » 21. Mär 2011, 08:19

Hallo Hexmaster!

Der Schreibschutz ist anscheinend normal. Den habe ich auch drin. Warum die INI-Datei nicht verarbeitet wird, kann ich Dir nicht sagen. Spamio selbst liest die nicht. Aber Spami lädt alle DLLs, die im Pluginverzeichnis liegen. Die wiederum müssten dann die zugehörigen Dateien verarbeiten. Ich denke, es ist an der Zeit, dass Du Dich mit der Macht vertraut machst....Ähhhh ich meine mit dem sysinternals-Tool Procmon.exe. Das startest Du als Admin und startest danach Spami. Wenn Spami fertig, beendest Du das Logging. Danach kannst Dir den Wust an Infos nach der Dll-durchsuchen und nachschauen, ob die versucht, an weitere Dateien zu gelangen. Je nachdem findest Du entweder eine Fehlermeldung dazu oder gar keinen Zugriff. Ich vermute ja letzteres. Du solltest auf jeden Fall vorher ein wenig mit dem Tool spielen. Ohne die eingebauten Filter wird man nur sehr schwer den Überblick behalten können.

Gruß
Andreas_Z

Re: DNSBL-Plugin

Beitrag von Hexmaster » 18. Mär 2011, 13:19

Ich möchte so schnell noch nicht aufgeben. Ich habe die ini noch gefunden. Sie war aber nicht im Programmverzeichnis von Spami, wo die dll ist, sondern unter:

C:\Users\<UserName>\AppData\Roaming\Spamihilator\plugins

Ist das so richtig? Dachte bisher immer, das ini und dll im selben Verzeichnis liegen. Ich habe hier im Forum ein paar Beispiele gefunden, wie die ini aussieht, das hab ich zum Test einmal übernommen, sieht jetzt so aus:

Code: Alles auswählen
[DNSBL]
DNSBL1=bl.spamcop.net
DNSBL2=blackholes.five-ten-sg.com
DNSBL3=blackholes.uceb.org
DNSBL4=blacklist.spambag.org
DNSBL5=dnsbl.sorbs.net
DNSBL6=dsn.rfc-ignorant.org
DNSBL7=owps.bl.reynolds.net.au
DNSBL8=relays.ordb.org
DNSBL9=relays.osirusoft.com
DNSBL10=relays.visi.com
DNSBL11=

AutoDisable=1
AllLines=0
NoHostnames=0
Logging=4


Ich gehe mal davon aus, das die ini so richtig ist. Aber Spami ließt die ini nach Start nicht ein. Warum nicht?

Andreas_Z hat geschrieben:Dazu mußt dann aber das Sicherheitskonzept von Windows aufweichen und Dir Schreibrechte auf den Programmeordner geben.


Meinst du jetzt den Programmordner selber oder den Ordner unter Users? Der Ordner Spamihilator unter C:\Users\<UserName>\AppData\Roaming\ hat einen Schreibschutz. Ich kann den zwar über die Ordner-Eigenschaften entfernen, das klappt aber irgendwie nicht. Rufe ich die Eigenschaften wieder auf, ist der Haken bei Schreibgeschützt wieder drinne.

Gruß Hex

Nach oben

cron

 industrious-southeast