Unable to obain certificate from Spamihilator

Antwort erstellen

Bestätigungscode
Gib den Code genau so ein, wie du ihn siehst; Groß- und Kleinschreibung wird nicht unterschieden.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:
BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet
Die letzten Beiträge des Themas
   

Ansicht erweitern Die letzten Beiträge des Themas: Unable to obain certificate from Spamihilator

Re: Unable to obain certificate from Spamihilator

Beitrag von Chactory » 15. Dez 2013, 00:06

Hmm ... imaginable ...
Have you successfully transferred the certificate to your Win7?

Re: Unable to obain certificate from Spamihilator

Beitrag von JMThomas » 14. Dez 2013, 16:48

I try to test things before I submit them. My screen shots were from my XP system.

But....


I tried it again last night on my XP system, and I was able to get a certificate from Spamihilator.

So I don't know what's going on, other than there was one round of Windows update between my original posting and my comment that this is a Windows 7 problem...

???

Re: Unable to obain certificate from Spamihilator

Beitrag von JMThomas » 14. Dez 2013, 00:41

First, this is a Windows 7 problem. XP works fine. Can't say for Vista or Win8.

I suspect some tightening up by Micro$oft of the certificate store interface broke the original Spamihilator implementation.

----

My use of port 995 is historical; that was the way Spamihilator first worked.

When I enabled the "automatically try to establish SSL" occasionally things would fail with the "unable to use secure connection, use unsecured? message. This bothered my spouse, so I went from port 110 to 995 in tbird.

The current circumvention is to set things up on my XP machine to fetch a certificate for the name of my choice, and export it to my WIN7 machine.

Re: Unable to obain certificate from Spamihilator

Beitrag von Chactory » 13. Dez 2013, 23:46

Sorry, but I do not know anything about the certificate ... But to me it seems not logical to use SSL/TLS between Thunderbird and Spamihilator. You can activate SSL/TLS "if possible" within the Spamihilator options. If you want, you could try to do this, so the secure connection works between Spamihilator and mail-server. HTH ... :?

Unable to obain certificate from Spamihilator

Beitrag von JMThomas » 7. Dez 2013, 17:23

I use my windows\drivers\etc\hosts file to map several different server names to 127.0.0.1 -- this makes the "connecting to ..." message give a meaningful name corresponding to the account that is currently trying to fetch mail via Spamihilator.

This scheme worked fine a long time ago when I set up gmail. Recently, Yahoo! went to SSL so I tried the same trick while reconfiguring, and I can't get a connection to Spamihilator.

Today, I get a prompted for a certificate. I believe Spamihilator is not responding to the request for a certificate. (Of course, after Windows gets the self-signed certificate from
Spamihilator, I will have to approve it as an exception due to the lack of a valid CA chain.)

To demonstrate this, I've defined a server name Spamihilator in my HOSTS file:
Code: Alles auswählen
127.0.0.1  Spamihilator
I can ping Spamihilator, so I know it resolves OK.

Next I configure Thunderbird to use it:
tbird server.png
tbird server.png (68.18 KiB) 3324-mal betrachtet


Then I try to fetch mail, and the windows opens:
add sec excp msg.png
add sec excp msg.png (33.87 KiB) 3325-mal betrachtet


Clicking on "Get Certificate" does nothing.
"Confirm Security Exception" is greyed out.

Suggestions, please?

PS: Changing the server name to 127.0.0.1 works, but then I've had a certificate from Spamihilator for 127.0.0.1 in my store for a very long time.

This problems occurs on Win7, but not XP.

Nach oben

cron

 industrious-southeast